Adding an AppImage appplication as a keyboard shortcut

I've installed a screenshot tool called flameshot following the instructions listed here under AppImage:

Despite following the step to create a symbolic link, running flameshot alone as a command from terminal does not work. I'm not bothered about this but unsure if it's related to the main issue.

I'm trying to launch the program via the Print Screen button as a custom keyboard shortcut and have added one as follows:

Name: Flameshot

Command: ~/Applications/Flameshot/Flameshot-*.x86_64.AppImage gui

Key: Print

But it doesn't work. If I run the actual above command from terminal then it does run the program as expected - I just want to be able to have this happen via the Print Screen button rather than the command. I have the app image located at ~/Applications/Flameshot

I am wondering if it's possible to do this and if so what I am doing wrong. I'm new to Linux and am not very good with paths etc. I only installed the tool via AppImage as it did not work via apt install flameshot

Did you run as sudo?

sudo apt install flameshot

I'm not on Zorin OS at the moment so I can't check.
Have you tried installing it via the repository?

sudo apt install flameshot
1 Like

Yeah I tried with sudo but get this:

sudo apt install flameshot
[sudo] password for shieldsi:             
Reading package lists... Done
Building dependency tree       
Reading state information... Done

No apt package "flameshot", but there is a snap with that name.
Try "snap install flameshot"

E: Unable to locate package flameshot


apt search flame*

Wow... The package was removed from the Main Universe Ubuntu in favor of Snap. I just checked.

Canonical is really starting to fray my nerves with their High Pressure about Snap.

Here is the .deb package - you can download and just double click to run the installer.


It wasn't found but the other suggestion seems to have worked, thanks for the help!

This has worked now thank you!

Sorry this is unrelated and can post separately if needed, but when I run sudo apt-get update it does this:

Hit:1 focal InRelease                      
Hit:2 focal InRelease                     
Hit:3 focal InRelease                        
Hit:4 focal InRelease                     
Hit:5 focal InRelease

before eventually failing to fetch anything. It says waiting for headers. Is this likely an external issue and I should try later? It was working fine last week.

I agree with this.
Sometimes the servers can get overwhelmed during high traffic moments. If that happens, try again a bit later (most updates are not so urgent). This is not common, but common enough to be noticed sometimes.

1 Like

OK thank you I will try again later

I'm able to find flamehsot in the repositories... but it's version 0.6.0.

In respect of updates, make sure that you get your updates from 'Main Server' and not your 'Locale' (country of where you are) server.


Thanks I've updated that now

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.