Adding Epson ET-2710 wireless printer


It was very easy to add the ET-2710 wireless printer.
But I ended up with printer functionality only. No scanning functionality.
So, I searched the internet and found this guide:

I downloaded the latest drivers and followed the guide.
Finally I ended up with 2 printers. The connection was established and the printer functions.
Finally I started the scanner software.
Unfortunately, although the printer is connected, the scanner software responds with an error and reports that there is no communication.
What did I do wrong?


I'm unsure if it's the same with your Epson, but back when I had my last printer under Windows, scanning only worked if the printer was plugged in via USB.

I once had the same problem on a new home construction I was doing (installing all the wiring for the computer network, entertainment system, etc.)... fixed that by getting a box that plugs into the USB port of the printer, then plugs into the network, to enable scanning over the network. It was slower than straight USB scanning, but it worked.

Found this, might help:

Sorry your having trouble but I recently bought the Epson ET-2826, I didn't have to do a thing Zorin just informed me that the printer had been found, went to scan a document and it just worked then printed no problem.
so only thing I can suggest remove the printer uninstall the drivers reboot and see if zorin will perform its magic again.
To be honest its all I've ever done with printers on Zorin no more hunting down drivers, I should point out that mine is connected by wifi.
Good Luck

I wil try if adding an usb-cable and see if that works.
However, I find that a bit unusual having a working networkprinter.


I tried adding the printer to another pc.
Zorin finds the printer and it's working fine except scanning.
The printer settings do not show any features regarding scanning.

I tried to search in the searchbox using the searchterm 'scan'.
Et voilá: a documentscanner is found.
I started the documentscanner. The software tries to find a scanner.
Unfortunately no scanner is found.
Maybe a usb-cable is neccessary for using the scanning feature of the printer.
But I was hoping (and expecting) that the scanner works without an extra cable.


On the left, expand “Network Settings” and click “Wi-Fi”.
You'll see a lot of details about how it is currently disconnected, but if you scroll down to the very bottom of the page, you'll see a button that says wireless printer “Setup”. Click it to configure the label holder!
The printer will search for available Wi-Fi networks.

Follow the guide on this Linux Mint forum thread:

Connecting the printer to a wifi-network is not the problem.
I have connected the printer succesfully to my wifi-netwerk.
Only if I connect an additional usb-cable I am able to use the scanner function.
That means that I can use the scanner-function if I use the desktop pc with an usb-connection.
Can you be more specific (screenshot?) pointing out 'you'll see a button that says wireless printer setup' ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.