Adding printer, Authentication adding printer username password

Hi all,
I am adding the printer from the windows network via samba.

All seems fine: - I can authenticate the access to the domain, - I can see the printers there. - Adding printer manufacturer ect...

But I stuck in the last point when I click apply button and see another authentication window which asks just Username and Password (without domain).

I can't figure out which username and password I have to type. I tried all, the current PC, the PC which host the printer, nothing!

Can you help me please?

Hi, Take a look here:

and here:

thank you so much for quick response. I will take a look and give feedback.

hello, so I tried as followed:

  1. Turn off password protected sharing -> FAILED
  2. Let Windows manage the HomeGroup -> FAILED due to HomeGroup removed from Windows 10 (Version 1803)
  3. Enter valid user credentials -> FAILED
  4. Add the target PC's network credentials to Credentials Manager -> FAILED
  5. Change request of a CUPS server authentication, which by default, has a value basic in config. And I switch it off by doing the following:

sudo nano /etc/cups/cupsd.conf
change the value DefaultAuthType to None
sudo service cups restart

-> No authentication required anymore , but everything stops, as if blocked!

So I followed the next step:
1. Open the file /etc/cups/cups-files.conf.
2. Find the group name at the line containing SystemGroup (in Ubuntu it should be lpadmin).
3. Add yourself to that group (sudo usermod -a -G lpadmin your-username)
4. Apply it (sudo service cups restart).
-> FAILED due to Print service unavalable! I had to remove command "sudo usermod -a -G lpadmin my-username" from cups-files to fix it back.

what I did wrong?

What is the make and model printer? You may need to install specific drivers for it.

It's a HP LaserJet Pro M15a. Actually when I start to set it up I find it in the list.

Have you tried

sudo apt install hplip hplip-gui

1 Like

I tried and that's the result:


I am writing this because I just tried to search and connect the printer from PC2 and I only needed to install python3 and smbclient AND IT IS WORKING!

The isseus to connect the printer I have with PC3. Between PC3 and the printer connected to PC1 there's the router ( and a switch, which works under is own domain ( PC2 is connected togheter with PC1 into the switch. It must be that one the problem for PC3!

This is what the command sudo arp-scan --localnet shows from PC3:
Interface: enp0s25, type: EN10MB, MAC: 18:a9:05:b5:aa:0d, IPv4:
Starting arp-scan 1.9.7 with 256 hosts ( 00:14:c1:36:cd:a7 U.S. Robotics Corporation (the switch) ec:3e:b3:51:e8:dc (the router)

What do you think?

1 Like

I think you're definitely on the right track. Is connecting in-line with PC1 and PC2 instead of the router possible?

Unfortunatly not, because PC3 and router are on separate room from PC1 and PC2 and I use ethernet cables.

Hello everybody.
I asked for help in a networking forum to fix the network settings. Now we have fixed it, putting the second router "transparent" and now the second domain 192.168.2.x does not exist anymore. Now each device has its own IP like 192.168.1.x.

Having fixed this, now let's go to the problems.
Now even PC2 (after having positively installed the printer) no longer wants to print: after sending the file to print, a window appears telling me that the printer asks for access credentials (and what are them ?!)

The PC3 on the other hand seems like nothing has changed. Maybe a settings reset is needed ... Help, I can't take it anymore!

1 Like

I was surprised that the router is set to usually indicates a private network and can't reach the internet.
In terms of the Computer that can print - have you checked the Printer settings and allowed shares from that PC? That might be a way forward? :wink:

Hi, yes that IP is set by the router of the provider. Of corse the printer settings has been set for the share:

It must be something wrong with comunication between Zorin OS and Windows 10...

Found this snippet:
"Double-click a Windows or Linux PC sharing a printer and you’ll see it shared printers. Double-click the printer to add and configure it. It will appear alongside your local printers in standard print dialogs."

Does this work?


1 Like

hi, yes I already did that and did not work. All the shares are set with no restriction and no passwords.

It is really strange that before, when the router-switch was set as router with is own IP domain, the PC2 could connect the printer shared from PC1 without asking any credentials. Now that the router-switch is set as "transparent" it does!!!


Suspect that this was caused by Windows ... but I could be wrong! :joy:
Does the router have USB ports? Could you not attach the printer that way and access it via router? Just a thought.

you mean try to connect the printer on USB port of the router? At the moment there is connected the esternal Hard Disk and all PCs can access without any kind of problems.

Pity it doesn't have two ports. Always been suspect of having an external drive accessed to a router. I only ever connect for backups when off-line but can understand if using it as a streaming device.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.