Admin permissions for external drive


I ran into problems with drag and drop regarding my NextCloudPi. I can't upload anything from a different drive than the system drive (speaking Windows here...) into the browser interface.

After some research it seems that I need to "give the admin group permission to use external storage".

Could someone point me in the right direction, please? I don't really have a clue where to go from here... Complete newbie :pleading_face:

Please ensure that your External drive is plugged in and mounted. If you can access it or see it present in your File Manager, then you know it is mounted.
You can then open the App menu and type disks. Click the Disks utility presented in the App Menu.
The Disk Utility will open giving you a Graphic of all disks currently mounted. Your primary drive, any usb drives, external drives, etc. Click on the rectangle representing the External Drive you wish to change permissions on.
Underneath that graphic is a list:
partition Type and Contents.

Device is the one you want to keep an eye on. When you select the External drive in the graphic, then Device will change to that Device I.D. It will look something like /dev/sdb1 where sdXX can be the variable, depending on that particular device I.D.

You can now use that information in the terminal to change ownership to YOU.
In the following, change $USER to your actual username that you use accessing root and your computer. Change /dev/sdXX to the device I.D. you got from the Disk Utility, above.
Open terminal with ctrl+alt+t keyboard shortcut and enter into it the following, changing $USER and sdXX as outlined above:

sudo chown -R $USER:$USER /media/dev/sdXX

The chown command is for Change Ownership. The -R sets it recursively, so that it changes ownership in all files, not just the Top Directories. $USER:$USER is you and the /media/dev/sdXX is the path to the external drive.

1 Like

What a super fast response! Thanks a lot, @Aravisian!

Now I pretty much got the gist of it, but I am still running into a problem after typing

sudo chown -R albi:albi /media/dev/sdc1

The output is:

chown: cannot access '/media/dev/sdc1': No such file or directory

Although it clearly says sdc1 in the disk utility:

Screenshot from 2021-06-22 00-18-46

How about:

sudo chown -R albi:albi /dev/sdc1

You might also try:

cd /media/dev/sdc1

sudo chown albi:albi

EDIT: hmmm... It shows it clearly mounted under /media in the screenshot you provided. But I also notice that it is formatted in Microsofts NTFS.
For that, maybe this:

I encountered a similar problem yesterday (permission denied, no drag and drop).

I am using openmediavault installed on Intel Computestick.

It turned out that I had to setup the shared directory for each protocol I need to use (ex., FTP, SMB/CIFS, SSH, etc.) and give a permission (read/write, read only, etc.) for each user.

While it is not NextCloudPi, I would imagine a similar setting in the web user interface exists.