After adding a python script to startup applications, xorg won't work

Using Zorin 16 Core

After a lot of months using Zorin, It look like I broke something hahaha

Basically I bought a gaming mouse, Logitech g203 lightsync, I wasn't feeling comfortable while using this mouse in Zorin and I decided to use a python script that I found on GitLab to change the DPI q3aql / zenidrv-g203 · GitLab

I added the script and its arguments to change the DPI in startup applications, restarted my pc and notice that the display now only display a terminal, tried to start xorg server and didn't work.

What should I do?

Using the tty or terminal, have you tried removing the python script that you added using the rm command with the path to the script?

I removed it from ~/.config/autostart, didn't work. I don't have it in my path, when configuration the autostart application, I used the specific directory to the script Ex: ~/mouse/

None of them, I installed it cloning the repo and added to startup application using the command

~/mouse/ lightsync dpi 3200

1 Like

Try to specify the full path (I assume your username is also redoz but update as needed) and even the Python interpreter:

/home/redoz/mouse/ lightsync dpi 3200
/usr/bin/python3 /home/redoz/mouse/ lightsync dpi 3200

Also, have you run all of the installation steps as described in the repository?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.