After installation. There is no Grub Menu. GNU Grub minimal Bash

Hi Folks,

Recently i wanted to try and install this distro besides my windows install. When i installed it after the restart it opens the grub menu normaly. When i restart the OS i see the GNU Grub Minimal Bash screen.

What i've already done;

  • Boot Repair
  • Installed it with and without updates.

Someone any idea how to fix this. I really want to use this OS but this right now is holding me back.

Kind regards,

By this, do you mean it is logging into the tty?

I don't know what you mean by TTY? But what i can say when i log in for the first time and then restart Zorin OS i get the Minimal GRUB menu.

Similarly, I do not understand what you mean by the Minimal GRUB menu.
Here is an image of tty screen in Ubuntu:

I made a picture of the screen;

I have never encountered that screen before. I had to look this one up.

This guide suggests using Boot Repair to fix.

1 Like

I already tried this. Didn't help tho

I assume you have been searching the internet for answers:
Here is one re Ubuntu which should also be good for Zorin.

Question: From live USB, did you install direct or use the "something else" method?
See this:

Which flavour of Zorin are you installing, Core or Lite etc.

I'm using Core. I installed it directly next to the windows install when i choose the second ssd. I will try the Something else method later tonight / tomorrow and see if that works. I hope this helps :slight_smile:

Just tried to do it the Somthing Else method. After the installation has finished and reboots the Grub menu shows, but after a restart the Minimal Bash screen comes back.

Did you check the SHA256 checksum for the ZorinOS file you downloaded.

I have never encountered the problem you are suffering, so am only able to feed you things I have found searching the internet. Here is another:

1 Like

I just tried to install another distro (Linix Mint) and i got the excact same problem. I wipe the whole ssd and still the same problem. Tomorrow i'm gonna try to factory reset my motherboard and hope that makes a differance. I keep u posted!

How many partitions did you have on the SSD when you tried to add Zorin?

Before i installed it. I completely wiped the drive.

So there is progress. The boot menu finally works as intended. BUT, there is another issue. When the install is done and installed to my SSD everything works. But when i unplug the install USB the whole Ubuntu startup drive in my boot menu dissapears. And when i select the drive where my boot menu and OS is it's says insert boot device. So.. i don't know what is going wrong here..

Sounds like it's writing the boot/grub to your USB disk.

If you install again, can you check where it's installing to?

Also from the terminal, after installation, can you type.

df -h

And send the results?

Or reinsert the USB and reboot.

See whether the GRUB menu appears and what the options are.

joost@joost-X570-AORUS-ELITE:~$ lsblk
sda 8:0 1 447,1G 0 disk
├─sda1 8:1 1 529M 0 part
├─sda2 8:2 1 99M 0 part /boot/efi
├─sda3 8:3 1 16M 0 part
└─sda4 8:4 1 446,5G 0 part /media/joost/58E23E16E23DF8B8
sdb 8:16 1 111,8G 0 disk
└─sdb1 8:17 1 111,8G 0 part /
sdc 8:32 1 1,8T 0 disk
├─sdc1 8:33 1 16M 0 part
└─sdc2 8:34 1 1,8T 0 part /media/joost/Turbo Gamedisk V2
sdd 8:48 1 931,5G 0 disk
├─sdd1 8:49 1 149G 0 part
├─sdd2 8:50 1 707,5G 0 part
└─sdd3 8:51 1 75G 0 part
sde 8:64 1 57,3G 0 disk
└─sde1 8:65 1 57,3G 0 part /media/joost/ZORIN OS 15

joost@joost-X570-AORUS-ELITE:~$ df -h
Filesystem Size Used Avail Use% Mounted on
udev 16G 0 16G 0% /dev
tmpfs 3,2G 2,3M 3,2G 1% /run
/dev/sdb1 110G 9,8G 95G 10% /
tmpfs 16G 0 16G 0% /dev/shm
tmpfs 5,0M 0 5,0M 0% /run/lock
tmpfs 16G 0 16G 0% /sys/fs/cgroup
/dev/sda2 95M 35M 61M 37% /boot/efi
tmpfs 3,2G 16K 3,2G 1% /run/user/121
tmpfs 3,2G 36K 3,2G 1% /run/user/1000
/dev/sde1 58G 2,3G 56G 4% /media/joost/ZORIN OS 15
/dev/sda4 447G 424G 24G 95% /media/joost/58E23E16E23DF8B8
/dev/sdc2 1,9T 1,3T 567G 70% /media/joost/Turbo Gamedisk V2

This is the SSD which it installed to.

This is my USB drive.