After new install Zorin 16.1 start hang up with "initramfs"

Hi All
Would need your help...
After installing Zorin 16.1, the boot process hangs with the error message: gave up waiting for root file system device - Alert /dev/sda5 does not exist. Dropping to a shell!
(Initramfs)
I don't know how to proceed now because I'm a beginner in Linux! I like Zorin, as a Life CD everything runs perfectly on my system.
With regards LackyLo

In your BIOS / EFI settings, are you set to RAID or to AHCI?
If you are Not Dual Booting Windows and if it is set to RAID, switch to AHCI and try running the installer.

I use no Dual Booting, there is only Zorin installed.
My BIOS is an Phoenix - Award Bios and there are no such points as RAID or AHCI to find. It is an HP Compaq dx 2420 microtower with an Intel Pentium processor, mainbord MS 7525 Ver: 1.0 Perhaps this hardware is not fit for Zorin?
Hopfully I must not let go of this Zorin idea, pecause I like it very much!

I am not yet ready to consider that as likely...
Please see here for RAID / AHCI for your machine:

Can you please tell me the size of your EFI partition? You would be safe to have it at 500mb
If it is too small, then it could cause the problem you are having.

If you are able to access TTY or Recovery Mode> Drop to Root Prompt can you post what is the result of

cat /etc/fstab

EFI only needs to be 50 Mb max! (Normally only needs to be 35 Mb but 50 Mb is what I choose when doing a manual install.)

I still recommend 500... It cannot be resized later so easily if needed.

boot - How to know the proper amount of needed disk space for EFI partition - Ask Ubuntu.

I think I was forgetting that this was the size in earlier renditions of Zorin and as the kernel has got bigger etc etc - also on my Devuan - no EFI - for once I let it do a manual install but with the proviso I have a dedicated /home partition, nothing else:

Oh thanks for staying tuned in!
Tried to get into raid/ahci mode with Ctrl+I(N), unfortunately without success, so again no idea whether the system is running in raid or ahci mode?
When I start Zorin in recovery mode I only get the initramfs prompt, have no idea how I can get a root prompt there?
When I rip with live CD I see: dev/sda1 fat32 512 Mb and dev/sda5 ext4 130 GB.

Can you give us make and model of computer? Also can you boot with live medium, run GParted and take a screenshot of the hard drive partitions and post back here?

It's pretty funny - When it comes to installing, I consider you a more reliable source than me.
It wasn't easy to voice disagreement on this.

All I can find out about the PC is: HP Compaq dx 2420 microtower with an Intel Pentium processor, mainbord MS 7525 Ver: 1.0 and a Phoenix - Award Bios.
Could it be that this BIOS does not support UEFI boot at all?

And here is a screenshot from the hard drive ...

Are you using an Encrypted setup?

I always thought EFI/ESP had to be Ext4, not FAT32?
Also I would have created the partitions manually with 50 Gb for '/' as 'root' partition for the OS, then create the extended partition with Swap Area double the size of your physical RAM at the end of the extended partition and everything in front of that as '/home' formatted to Ext4!

No ... just a normal install

I did a standard installation because I'm new to Linux and I have no experience with it... but it's worth trying on your suggestion, maybe I'll succeed and I'll learn... :thinking:

Hi
Yes, I tried a manual installation, but failed because I don't have the necessary knowledge to do so ... unfortunately! Have now tried to install Solus Linux on the same system, worked immediately! Now I'm wondering what makes Zorin different that my machine can't digest? It's a shame because Zorin OS would have been my first choice for my switch from Windows.
Nevertheless, thank you very much for your effort! And if we can think of anything else to get Zorin running I'm totally open to it.