After removing iptables; ping failing Zorin OS 16

Can you try changing the range?

sysctl -w net.ipv4.ping_group_range="0 1000"

here it is

Also now can I remove that bloat firewall as star treaker said that I dont need it in home wifi!

Fascinating. Maybe it is a permission issue:

sudo chmod 4711 /bin/ping


Reboot - then test.

I am back still same issue!

Why me only :frowning: :cry: :cry: :cry: :cry:
I am ultra unhappy please help me I don't want to go back to that world's super slowest OS windows.

1 Like

I think you and I can agree that the testing with SSH and IPTables must have had some effect, here.
We just did a rapid fire check of things until I ran out of ideas.
I dislike suggesting this option but: I wonder if re-installing Zorin OS may be the way to get it fixed and a clean start without driving yourself crazy.
This time; Do not install IPTables firewall, since Zorin OS comes with UFW already (And you can remove UFW if you really want to).

Please I don't want to reinstall I have my whole world in zorin os so I can't lose 200gb of data suggest me anything else please.

As @StarTreker suggested in the other thread, had you checked your Router settings?

Yes no issues with router as windows is able to ping and connect to ssh. I tested it on my brother's windows.

You cannot assume everything in the Router is valid just because Windows works. Windows may have exceptions.

Ahh trust me its valid :cry:
ok tell me however what to check in router ?

I have no idea- I do not have your make and model of router.
It varies by Manufacturer.
I can only make these suggestions... It's better to have full certainty than to assume for the best.

Are you using a VPN?

Nope I am just using cloudflare linux cli for faster dns lookups

You might try:

sudo apt install --reinstall iputils-ping


I also tried removing cloudflare but still not working and one more thing I forgot which one i installed previously can you please help

Which one I need?

Ubuntu Focal

1 Like