Airplane Mode

Hi Aravisian
I found the command it wanted me to input and it said sudo: tee/etc/modprobe.d/thinkpad.conf: command not found

This one?

echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/thinkpad.conf > /dev/null

Sorry I did try it as you typed it with no luck, after putting in the command string I got a return of

[sudo] password for vinny: echoblacklist ideapad: command not found

sudo: tee/etc/modprobe.d/thinkpad.conf: command not found

I do not understand why when you post the response that gave you "command not found" the spaces in the command are all wrong.
Can you please Copy and Paste the command into your terminal?

1 Like

and the " " marks too! :wink:


Goodmorning Aravisian
As you can see aftering the command statement it asked for my password were you see the space I entered my password pressed enter, then it printed the next line that starts with suto:

Look at your command and the one @Aravisian posted. Your still missing spaces (or the _laptop part). It won't work if you don't take it over correctly!

Why don't you copy and paste it into the terminal ? like users suggested already ?

echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/thinkpad.conf > /dev/null

Here a sample:

1 Like

If you prefer GUI:

sudo -i


Navigate to /etc/modprobe.d and right click an open area in the directory.
Create a New Document.
Name it thinkpad.conf
Place this line into that document:

blacklist ideapad_laptop

Save and exit.

Hi Aravisian
As you requested everything is done. Since the command line was long I took Michel advice and cut and paste the line. then after doing what you requested I took a screen shot and this is what I received.

1 Like

Good job! Does it make any difference ?

Hi Michel
Nope still can't turn off airplane mode. I'm thinking I may have to wait until a new update with the fix in it comes out. For now, I have been tethering my cell to the laptop and that allows me to get on the internet.

@Aravisian, would these commands help him ?

sudo rfkill list all and sudo rfkill unblock all


sudo rfkill unblock wifi

Hi Michel
Just tried all three commands with no luck, like I said maybe I will have to wait until a new update comes out and maybe will fix the problem.

1 Like

Does anyone know if Zorin is coming out with an update that will fix the Airplane Mode problem? It seems I'm not the only one with this problem. I can still get online but only if I tether my phone to my laptop for now I can live with it.

Did you check this ?

Play the video at time 3:22

1 Like

Hi Michel
I am quite embarrassed, I do not remember hitting that switch wow! I think I owe everyone an apology in the forum. I watched the video that you asked me to watch Michel and flipped the switch and the airplane mode shut off. I must have hit the switch while I was putting the laptop back in the case and not realizing it. Because I got the new update around the same time. Well if anything, I learned some things about Linux and Zorin if it means anything. Thank You for some lessons that I have learned for You and Aravisian. Maybe in the future, if someone has the same problem bring up the switch on the side of their computer that just maybe not realize the switch got hit and switched off.. Anyway Thank You for your patience in this matter.

1 Like

It just popped out of my mind because i remembered another user had the same problem back in august :sweat_smile:.

Please mark the post as solved :grin:

Hi Michel
What bothers me is it is a flush-mounted switch and to move the switch? again WOW. :grin:

1 Like

You will never forget to check that switch again when you see your in airplane mode again :stuck_out_tongue_winking_eye:

Take care and enjoy your awesome distro @VinnySx :sunglasses::+1:t2:...zorin has landed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.