Airplane Mode

Hi
I am new to Linux, I noticed that the airplane mode is on and all the switches are grayed out. I have tried every terminal command that I could find but nothing seems to work? I have looked into the wifi and it says shut off airplane mode, however, since the switches are grayed out I can't do anything. Any thoughts and is there a program I can install to troubleshoot this problem?

Thank You
Vinny

1 Like

Try wireless - Turn Airplane Mode on/off via terminal - Ask Ubuntu

Hi carmar
I went to the site in the link, however, nothing worked? When I try to turn the wifi on for a split sec I see the wifi screen then the airplane symbol appears for some reason it will not allow me to shut the airplane mode off. I even tried signing into the system as a root user.

You mentioned using every terminal command you could find.
Did you use rfkill? Modprobe?

Hi Aravisian
I did try using rfkill even as a root user. What is Modprobe?

Module Prober.

Can you please post the output from terminal of:

sudo lshw -c network

Hope this helps you?

vinny@vinny-ThinkPad-T530:~$ sudo lshw -c network
[sudo] password for vinny:
*-network
description: Ethernet interface
product: 82579LM Gigabit Network Connection (Lewisville)
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: enp0s25
version: 04
serial: 3c:97:0e:7b:e6:08
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.11.0-43-generic firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
resources: irq:28 memory:f3a00000-f3a1ffff memory:f3a3b000-f3a3bfff ioport:7080(size=32)
*-network DISABLED
description: Wireless interface
product: Centrino Advanced-N 6205 [Taylor Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 34
serial: 84:3a:4b:60:8b:78
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-43-generic firmware=18.168.6.1 6000g2a-6.ucode latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:32 memory:f3000000-f3001fff
*-network
description: Ethernet interface
physical id: 2
bus info: usb@3:2
logical name: usb0
serial: fe:c7:a8:86:3e:77
capabilities: ethernet physical
configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-43-generic firmware=RNDIS device ip=192.168.42.26 link=yes multicast=yes
vinny@vinny-ThinkPad-T530:~$

This driver should be fully working in the Kernel. And given that you seem to have no control in the software...
Many Notebooks, etc. have a Physical Switch for the Airplane Mode or Wifi.
It may not be obvious; sometimes it is a FN-Key combo from the keyboard.
Have you thoroughly explored this, yet?

1 Like

When I use the Fn F5 key I get a message that says Hardware Airplane Mode
it seem after using the key nothing happens? It does not shut it off or on?

Ensure you do not continue holding the fn key...

You may also try running it from tty (as this is like safe moding it).
Use ctrl+alt+F7 to Exit (remember this!) from the tty.
Use ctrl+alt+F3 to Enter TTY.
Enter your username and password, then use the keyboard shortcut to disable Airplane mode.

Also - in BIOS is Secure Boot disabled or Enabled?

Hi Aravisian
OK, this is a little over my head, question do you know if there is a diagnostic tool out there that maybe I could use. For now, I can still get on the internet by my cell with a direct with USB Tethering

None other than the GUI Network settings that comes with Zorin OS.
However, I am quite confident you can follow the above steps. You can use the ctrl+alt+F3 keyboard combo to enter tty. Enter your username and password. Then use the Wifi / Airplane mode keyboard shortcut you mentioned above; Then exit tty with ctrl+alt+F7.
Believing in yourself is the first step toward independence.

1 Like

Enter grub and switch to kernel 5.11.0-40

UEFI hold the escape button during boot
Legacy bios hold the schift key during boot

Yesterday i got another user that could not use the wifi anymore after updating to 5.11.0-43

That last kernel gives regression to some users

Hi Michel
Sorry I am very new to Linux. Could you be more detailed with your instructions? You are correct. This happen after I received a major update the other day.

I thought i was clear, but i explain it a bit better

  1. Reboot machine
    1a. If you have a UEFI machine hold the escape button during boot to enter grub
    1b. If you have a Legacy bios hold the shift key during boot to enter grub
  2. When you are in grub press advanced mode
  3. Select kernel 5.11.0-41 (the normal one, not the recovery)
  4. Check if the problem is gone, if yes open up terminal and write this
sudo apt-get purge linux-image-5.11.0-43-generic
sudo apt-get purge linux-headers-5.11.0-43-generic
1 Like

Hi Michel
Thank You for clarifying the process for me, I have the Legacy bios and proceeded as you asked. However it has not worked? Any other ideas that I may try? Something I noticed when getting into the Legacy bios I noticed two different choices one was Zorin, with Linux 5.11.0-43-generic and the other was Zorin, with Linux 5.11.0-41-generic The other thing I noticed was both UEFI and the Legacy worked to get to the same screen?

Did you try that one or the 5.11.0-37 one ?

Hi Michel
Yes at this point why not. Neither one of the choices worked? Any thoughts!

Hi Michel
Sorry, I must be loosing it, I do not have one that is Linux 5.11.0-37?

Can you post a photo of that menu, easier to talk :grinning: