Airpods 2nd gen won't pair on Dell Inspiron 7778 laptop with Intel wireless 3165

When I try to pair them it loads but then it goes back to "Not set up". Sometimes the attempt to pair crashes the Settings app.
I have other partitions with ElementaryOS and Windows and they pair seamlessly on both. No issues pairing with my iPhone either.
The Bluetooth adapter works on Zorin OS because I am able to pair other bluetooth headphones and devices. The issue seems to be specific to the Airpods afaik.
Solutions I've tried from the top answers in these forums:

  • Controller mode = bredr

  • Pipewire

  • Hide Pulseaudio

  • Try to connect, restart PC, try to reconnect.

I had the same issue with popOS, what is ElementaryOS doing differently? Aren't they all based on ubuntu drivers? Is there any hope for my Airpods working with Zorin OS?
Thanks.

I have never had an issue using the bluetooth interface on any ubuntu based systems. Have you tried just putting the airpods in pair mode and then connecting them via the bluetooth applet in the taskbar on Zorin OS?

If that isn't appearing go to Settings > Bluetooth and select the airpods from there.

Yes, I put the airpods in pairing mode (white flashing led) and select the device in the bluetooth settings.
It loads for a second and then reverts to "Not set up". The settings app crashes occasionally while attempting to pair.
I just tested another pair of Airpods Pro and they have the same issue.
The Airpods connect seamlessly on ElementaryOS, no idea why it fails on ZorinOS.
The bluetooth adapter is functional in ZorinOS because I can pair other bluetooth headphones. This is an isolated issue with the airpods.

1 Like

Airpods are an Apple product and are therefor proprietary.

This doesn't mean that they can't work, but it may mean extra fiddling may be required. Similarly, some things work on Zorin out of the box, but not on other distros. It's a really Good Question: What is different on Elementary?

Can you please look at the terminal output of:

sudo nano /etc/bluetooth/main.conf

Arrow key down to

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
#ControllerMode = dual

Remove the hashtag # from ControllerMode and change the value to bredr

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
ControllerMode = bredr

Tap ctrl+o to overwrite, then enter key, then ctrl+x to exit the editor.

Reboot the computer and try pairing. If still not working, you can leave that configuration as it is. It may still be helpful later.
What is next is to check Pipewire and Pulseaudio...

Remove the hashtag # from ControllerMode

Wow I feel stupid. This is where I made the mistake, never removed the hashtag after changing it to bredr countless times. Thank you fixed.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.