All applications view and Activities overview constantly overlap?

Hello all, new forum member, linux tinkerer for 15 yrs. I have been trying out core 16.1 lately on a macbook air mid 2012.

All is well except... 1 issue i can't seem to overcome. After install or possible reboot, when i initially hit super key i get a clean activities overview. I can search, change desktops etc. Once i ever hit super-a to show all apps continue on then go back later to hit super key to open activities overview, all applications show underneath. If i then search, search results impose on top of all applications. This makes for a hard to read jumbled mess. I have disabled all shortcuts so that super opens zorin menu, alt-a opens all apps, and super-f opens activities overview. Unfortunately, this does not help. Still the jumbled screen of all apps, windows open and search on one screen.

Any ideas of how to remedy this. Zorin seems to be ideal accept for this one deal-breaker that i can't seem to fix. I have done fresh install x 2 with seperate downlods and still the same issues. Thanks so much for any help you might be able to provide, Grace and Peace!

Ps... I have searched high and low online for zorin/ubuntu issues r/t this and have gotten nowhere before posting...

@RefriedSoul , would you be able to post a screenshot to visualize what you are describing?

Yes, thank you so much... one pic is when opening overview and windows open, next is when searching in overview.


That clarifies things a great deal. It looks like the gnome-extensions in use are both running simultaneously instead of one being closed when the other is launched.

I do not use Gnome as I prefer Zorin OS Lite or another desktop (Zorin OS Cinnamon Desktop). So I have little experience as to the frequency of this action.
Perhaps other regular Gnome Users can check this out and speak up if they experience the same.

You might try resetting it:

dconf reset -f /org/gnome/

This will punch you back to default on all fronts so be warned...

Do you have any extra extensions installed in ~/.local/share/gnome-shell/extensions?

There may also be a corruption in the extension. You can try reinstalling it:

sudo apt install --reinstall gnome-shell-extension-zorin-dash

This behavior begins upon fresh installation so there are not any other extensions installed that I'm aware of.

Aravisian, I appreciate so much the tips you have given me. I will be back on my system within the next couple of hours and I will try these things you have told me and post back.

1 Like

Tried all of the above suggestions. No extra extensions installed. Did the reset, and extension re-install. Still the same behavior. Thanks! Any other ideas?

Please install Gnome Tweak tool:

sudo apt install gnome-tweaks

Navigate to the Extensions tab and disable all extensions.
Next, test the activities overview and see what is working (If something does nothing, that extension is disabled...) and begin enabling extensions one at a time until the error returns.
Hopefully we can narrow down the culprit this way...

1 Like

Aravisian, we may be on to something here... Tweaks installed, i tried it right after turning off all extension with same problem, but... After reboot no extensions active, sort of looks like vanilla gnome. I can go back and forth super-a, super for overview with no overlaps as in previous photos. It appears to be working correctly with no extensions active.

So i assume i will re-activate one by one and see when problem reappears. I may not be able to check them all tonight but will definitely have time tomorrow. Thanks so much for your guidance! Will report...

2 Likes

Well, I have started testing each extension one by one and it only starts happening after I enable Zorin taskbar :frowning:

All others seem to work fine. I'm going to try to see if the dash will work for me.

Dash works correctly with Overview, except now when I click all icons they're really small but I can live with that until I figure it out. Aravisian, Thanks so much for your help.

PS...Seems to be a problem only in the standard desktop layout. Out of the 4 layouts in core if i choose the one with the icons in the middle, so far no overlay as in the above pics... so far...