Alsamixer settings return to default on reboot

Hello. I am very happy with my Zorin Pro, but am having a problem with alsamixer settings. By default the audio speakers on my Acer laptop remain on even with the headphones or earpods plugged in but the speakers should mute. I went into the alsamixer settings and made the change that does cause the computer speakers to mute once the jack is plugged in and it works great.

BUT, upon restarting the machine in the morning the alsamixer settings revert to their defaults and my settings are lost, so the speakers on the computer remain on when the headphone jack is plugged in.

I have searched around and tried some remedies such as adding "alsactl store" in the terminal but those remedies do not work.

Does Zorin have a file somewhere that needs to be edited so I can have the headphone jack work properly to mute the speakers?

Thanks for help!

  • Jeepy

Thank you for taking the trouble to reply. That link is one of the remedies that does not work. When I type "sudo alsactl –file ~/.config/asound.state store" into the terminal I get an error message saying "alsactl: Unknown command '–file'..."

To save your alsamixer settings, use:

sudo alsactl store

That has always worked for me.

Thanks for replying. But as stated in my original post I have done that and it does nothing to remedy the problem. Swarfender437 replied with the link to a remedy that addresses the fact that "sudo alsactl store" does not work anymore, but again, that remedy for the failed remedy yields an error message.

~ Jeepy

Taken another look and it should be two dashes followed by file not an en-dash:

Ah and that is not how it's shown on the linked website: Alsamixer not saving settings after restart | Techie Show

I'll be darned.. I'll try it with the change and report back. Thanks again!

Nope. Darn. Nothing's working. All I have to do is logout, not even reboot, and the alsamixer settings are lost. The relevant setting is the "automute" which by default leaves the speakers on when the headphone jack is plugged in. So I change that to "enabled." That setting is lost on logout or reboot.

Thanks for efforts so far. Please let me know if you have any suggestions. Wondering about PulseAudio if it defeats my settings in alsamixer. I have tried looking around there but there isn't anything that addresses muting the speakers when the headphones are plugged in.

This is strange and I've not seen it reported in other distros. :frowning:

~ Jeepy

I'm using Devuan 3.1.1 and after install one of the first things I did was to add all ALSA packages apart from Jack and OSS and removed Pulse Audio which is named 'pulse' via Synaptic Package Manager but do have Pulse-Alsa emulation package installed. I have to blacklist HDA Intel (name given to HDMI sound source even though the board is all AMD!). Another thing you could try is to

sudo chown [user name] etc

(You will need to change directory

cd ..

several times to get to '/' directory first, create a folder called 'pulse off' and drag the 'pulse' folder into it. You will now have nothing but ALSA present. To be clear I've never had to do what you are doing. I'm fortunate to have bluetooth headphones for PS4 ironically called Pulse 3D and work immediately, even built-in mic gets picked up instantly.

Also, did you read this on the man page I gave the link to?

"The configuration file is generated automatically by running alsactl store . Editing the configuration file by hand may be necessary for some soundcard features (e.g. enabling/disabling automatic mic gain, digital output, joystick/game ports, some future MIDI routing options, etc)."

Sorry, I just read the link posted by Swarf and was not aware of the failing store command.
I am still on Z15.3 Core, so maybe something in Zorin/Ubuntu since then affects alsamixer. That settings store problem worries me, as like you I also depend on alsamixer settings to get sound to work.

Yeah the problem of the failing store (and restore) setting was addressed by that tech in the provided link. It seems to have worked for some, but is not for Zorin and perhaps the related Ubuntu release as you mention. Looks like I'll have to live with it and re-search now and then for a remedy. I want my daily driver to be Zorin, and this issue is not a true deal breaker for that, but I am glad I've kept other distros on other hard drives. :wink: