AMD Framework 13 Support

Hi all, I just got my Framework 13 with the 7840U and I'm getting terrible performance in games. Like, 10 seconds per frame in even the simplest games like TF2 (Don't even get me started on Proton games). My assumption is I don't have the right drivers for the 780M, and installing the package/script from AMDs site isn't supported on Zorin. Anyone have better luck than me? Zorin OS Pro 16.3, kernel version 5.15.0-94 -generic

Edit: Upgrading to Zorin Core 17 fixed it

It's possible the laptop might be too new for the kernel. Maybe Zorin 17 with a newer kernel will work better?

2 Likes

That came to mind too. I tried using the Ubuntu kernel manager hoping they were similar enough it would run a newer kernel, but no boot so back to 5.15. Looks like an upgrade may be in order

Welcome to the Forum!

So, now Your System works, Yes?

1 Like

Yep, even Proton experimental gets me ~60 FPS in No Man's Sky on mostly high settings. Incredible how far integrated graphics have come

1 Like