AMD GPU with Core Control not running full speed

Good Morning/Afternoon or Evening Everyone.

I trust you all are doing well. Sorry being new to Linux I have a lot of questions. Most got working through Google. Not sure if this is the correct place to ask questions about Core Control.

Being an IT Technician for quite some time. I run monitors for everything. Back in Windows, I ran Aida/speccy/Radeon drivers and a few others. Now Core Control works exactly like AMD's software, but the problem is that my GPU only boosts to 1169 and my watt only goes up to 94w but most of the time it runs below 60w.
I did unlock the watt to go up to 134w ( GPU is an RX 470 4gb sapphire platinum edition ) 120w

When I have time I play some older games like Torchlight 2. Now on new games, I get better performance than a 2012 game. It can be that my CPU is too weak as they still made games for single-core performance then but you can alleviate
a little by running on high settings so you are more GPU bound. Doesn't matter what settings I run, I get the same performance. This also doesn't apply if I run a GPU-intense benchmark.

I never use to do custom fan curves for GPU but I had to do it with this GPU as it ran toasty. The only thing I can still try ( when I have time ) is to overclock this GPU and see if she boosts to the overclocked frequency. It may also be that my undervolt decrease the boost speed but that should not happen as it is set to full boost ( Personal Opinion, Core Control gives more control over AMD GPUs than MSI afterburner ).

Thank you and Sorry for the long post.

This has been here a while without address. I have never even used an AMD CPU or GPU so cannot speak from experience.

But from a computing standpoint:

To me, this usually suggests checking carefully for heat related issues. Ensure thermal paste is not crumbled or cracked. Ensure radiator fins are in good shape and clean. Ensure fans are clean and running smoothly without bearing issues and so on.
It is amazing how often it is something hard to notice - like an older fan that seems and sounds fine but is actually turning ever so slightly slower than normal...
Or some hard to notice fuzz trapped in a heatsink insulating it.

Thank you. I need to replace thermal paste when I have time ( My supplier are like 80km away ) I had heat issues because it's a blower style GPU so I set up a custom fan curve which tops out at around 71c

Yes it is load but I have a big sound system so noise doesn't bother me ( and I have a server that sounds like a jet taking off when she starts :grin: ) I did overclock and I got same results. It does not breach 94w. I only have this gpu for a little while. Windows did detect it correctly as I have bought Aida64. Problem is that Aida crash when asking for GPU specifications.

It may just be a sensor problem ( highly unlikely ). A Client had the same problem with Windows on an R9 Something can't remember. I downloaded and reinstalled the original bios and it fixed his problem. I am getting a 4th Gen I7 next month where this GPU will reside in. The reason I am only going for 4th gen is. First, it's bloody cheap and 2 it will be my work pc with web development, etc + study pc..

Thank you. Going to run some more tests and see what this GPU push ( aida64 ) ( Edit: it does not work.... Used Basemark. ) stress test should work.

EDIT: Sorted... For some reason, it put my PC on compute instead of 3D so it only ran in state 6 instead of state 7.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.