AMD GPU works in Windows 11 but not Zorin?

Should I be seeing my GPU in Zorin like I do in windows 11? Attaching my system details, its as if Zorin doesn't think I have a GPU, I am not a Zorin guru just yet.

Should I even see it here?

Welcome to the Forum!

On ''Processor'' stands ''AMD Ryzen 5 7530U with Radeoon Graphics''

Did you looked in the Gnome Settings on the last Menu Point Info? There should be Your Graphics shown:

Thank you for patience with my newness. Do you mean this?

That's no Problem. Everyone starts sometimes. I'm not very long on Linux, too. Yes, that it is. And it shows Your AMD Graphics. But You want to see what Graphics exactly?

1 Like

If you don't mind doing a little command, you can do this:

sudo apt install inxi
inxi -Ga

I guess it's kind of a dumb question, when I went to install something it was stating "no GPU found." (in Zorin) So I wasn't sure if it was actually using it. Perhaps windows 11 fakes it? Just wondering why I see a GPU in Windows, but not in Zorin from what i can gather.

@Storm, thanks for the command. Not afraid of the terminal, ran that and I see:

Graphics:
Device-1: AMD Barcelo vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: DP-2,DP-3,DP-4 off: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:15e7 class-ID: 0300
Device-2: Chicony Integrated RGB Camera type: USB driver: uvcvideo
bus-ID: 1-4:2 chip-ID: 04f2:b798 class-ID: fe01 serial: 01.00.00
Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.1
compositor: gnome-shell v: 43.9 driver: gpu: amdgpu display-ID: 0
Monitor-1: DP-2 model: Dell P2717H serial: YKNFG7AIAFYS built: 2017
res: 1920x1080 dpi: 82 gamma: 1.2 size: 598x336mm (23.5x13.2")
diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-2: DP-3 model: HP 22cwa serial: 6CM619176J built: 2016
res: 1920x1080 dpi: 102 gamma: 1.2 size: 476x268mm (18.7x10.6")
diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-3: DP-4 model: ViewSonic VX2476 Series serial: UPA183302790
built: 2018 res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x296mm (20.7x11.7")
diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon Graphics (radeonsi renoir LLVM 15.0.7 DRM
3.54 6.5.0-27-generic)
v: 4.6 Mesa 24.1~git2404140853.6cc780~oibaf~j (git-6cc7801 2024-04-14
jammy-oibaf-ppa)

1 Like

Well, it shows here and the correct driver is loaded. You could try switch between xorg and wayland to see if Gnome picks it up.

Thank you again Storm. I tried that, and I think I'll have to get over not seeing a pretty little GPU graph. :slight_smile: I used your suggestion logging out and trying xorg again. Now I ran the glxgear command: glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
519 frames in 5.0 seconds = 103.751 FPS
301 frames in 5.0 seconds = 60.004 FPS
301 frames in 5.0 seconds = 60.002 FPS
301 frames in 5.0 seconds = 59.998 FPS

I think my GPU is running correctly.

2 Likes