Android Emulator

Hello! anyone know of a good android emulator that I can install on Zorin OS? and that is not genymotion, that one I already tried.

Anbox is the one I use, don't know if it will fit your needs or not as it is not in active development to my knowledge

If you had performed a search of the forum you would have found Waydroid android emulator & anbox error, Are there Android Emulators for Zorin?, and What is the Best android emulator for zorin? which is not all the topics on this subject. Waydroid and Anbox are the most commonly used.

Please use the search feature in the future prior to creating new topics.

It may help you to read Intoduction to General Help which is a great guide for posting.


If you browse the Forum, and try to install Waydroid and Anbox in the ways that users recommend but fail to install any of the 2, even try other ways, but fail.
I even tried a form that was indicated on the official site, but it never started.
Do you know any other way to install Waydroid?
or any other?

This user has tested on Zorin OS 16 and provides a set of install instructions:

Please take careful note of the link at the top which leads to:

Yes, I tried, but I got stuck until this part, where I got an error:


Try installing via "Software" .

I use to use Android Studio (IDE) on windows, Great tool.
I see it's available via the Software app.

search "Android" in the Software app.
Hope this may help.

You can try

make clean


sudo make install

and see if that works.
If not...
I need to try installing this later when I have a chance to try to see what is going wrong.
It is interesting that Android Emulation has much Better support on Windows (Bluestacks) than it does on Linux, in spite of Android being originally based on the Linux Kernel.

It says "Permission denied", I understand that this is because "root" is the owner of that folder, instead of my standard user.

(sorry for the spanish)

Yes, I saw that was a good option, but I turned away when I read that it was only for use by application developers. Since the only thing I want to do is to install applications, which I can't install in Genymotion. Also, I was curious about the fact that android would run using the linux kernel. But I will try it, thanks.

1 Like

It also varies by application. If the app you wish to run depends on Google Play, you may run into trouble even with the best emulator, properly and fully installed.

The question is that I just want to install an android emulator to test some applications (games) and see how they would perform on my computer.
If I can't install Waydroid, I can try to install Ambox.
Do you have any guide on how to install Anbox for Zorin OS?

Well, I managed to install it, now, how can I install applications?

Ensure you have ADB installed;

sudo apt install android-tools-adb

You are venturing into deeper waters than I ever swam into. I am not sure, myself.
What I do know is that Android apps travel as .apk pacakges.
You can push .apk packages into Anbox with ADB or by moving them over yourself. Again, I have not done this, so let me see if I can find a guide.

This one seems to cover the basics:

so.... It worked xd
Thanks for the help!
I would have loved to install Waydroid, but with Anbox I think it's more than enough.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.