Another Wifi/bluetooth issue post

Note I'm a Linux noob

About to pull my hair out having spent most of the entire day looking for a solution. I've just put together a new PC and decided to dual-boot Zorin w/ Windows as I did my previous build which worked with no issues out of the box. Not the case now as both the WiFi and bluetooth adapter don't seem to be recognized.

I'm thinking it may be a driver issue but I don't have the Linux know how to diagnose/fix so hopefully someone can help! What I'm working w/:

  • Gigabyte b660m ds3h ax ddr4
  • i5 12400
  • 5.13.0-30-generic kernel
  • I've already disabled secure boot
  • WiFi works in the Windows partition
  • sudo lshw -C returns:
 *-network UNCLAIMED       
   description: Network controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 14.3
   bus info: pci@0000:00:14.3
   version: 11
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix cap_list
   configuration: latency=0
   resources: memory:4251c000-4251ffff
  • It appears as I have the right intel drivers in lib/firmware but, again, I'm a super noob so not sure.

You'll need more to diagnose for sure but I don't want to just start throwing random info out -- any guidance appreciated!!!!!!!!!!

Can you please

sudo apt install inxi

Then, relay the output of:

inxi -N

****VM-Zorin:~$ inxi -N
Network:
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge 
  driver: piix4_smbus 
  Device-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
  driver: 8139cp

Here ya go. Thinking it could be an issue w/ the kernel, too. I tried Fedora, EndeavorOS, PopOS, and Manjora and no issues with detecting the adapter. Zorin and Elementary both would not detect and are running older versions

Apparently there has been a long standing bug with i2c-piix4 driver:

https://www.kernel.org/doc/html/latest/i2c/busses/i2c-piix4.html

As this falls primarily to the hardware manufacturer, the likeliest thing to happen is that the manufacturer will drop support rather than correct it.

It may be that there is a fix but I cannot find it. I would recommend switching to using a well supported Wifi Dongle.

1 Like

Just read that article Aravisian and there is reference to updating the BIOS to see if that helps - might be worth a try if there is an update to the motherboard's BIOS?

1 Like

Ah, thanks for finding that ---- right now I'm just going to keep running Fedora and leave Zorin in Boxes if I want to play around in it. Thanks!!