Any USB writer other than Balena Etcher?

I was looking forward to experiencing the new Zorin after being gone for many years. However, I started downloading the .iso, and then saw that it was suggested that you had to use the balenaEtcher writer, so I downloaded it also. I got both downloaded, and tried to install the bE-w, and immediately got two error messages one on top of the other, the first one said, "Cant write to C:\users\\app-64.7z", I closed it, and the second one said "Not enough free space on C: please remove files and try again". I have a 1TB HDD with less than 550GB on it, if 450GB isn't enough for a usb writer, I don't want it LOL.

I figured it was just a bad download, so I deleted it, and tried again 3 times, same thing every time. So I gave up, and continued my search for a new distro. Then I said, "no I really want the new Zorin", so I came back and found the forum, personally I would rather email customer support, but I didn't see that option unless you bought pro, if I'm wrong, oh well, I've already asked here. Nothing against a forum, but I would just rather go to a mechanic than a parts house to get my car looked at. Although the parts house can be quite accurate depending on who's there.

Anyway, I tried at least 6 other usb writers, and they all said they could not mount/read/or write the Zorin file? So I have to wonder if it's written in Mars-han? LOL I joke a lot so nobody get offended. I'll take whatever suggestions anyone has to offer.

If you are using Windows, I recommend Rufus.

On Linux, I prefer Ventoy, now... That @pazoff wrote a post about it that got me hooked on using it.

Never recommend Balena-Etcher... too many errors, too many destroyed USB Drives.

1 Like

I tried Rufus (before I even tried bE didn't work), and I tried Ventoy, didn't work, I can't find anything that will mount and read the Zorin file, and I guess after reading your post, luckily I can't get bE to do it either.

I use Mint Stick.
This will install 2 apps Memory formatter and Image writer.

I usually format USB before write image on it.

This is a first... I have never seen this particular complaint before.

Are you trying to make a Zorin installer in Windows?
You could try this:

It's probably my broke down Dell laptop that is the problem. I'm not getting the performance I should based on the specs this thing has. It was one of the bargain basement sale items they do occasionally, where they take a Pentium 2 and dress it up like a I5, then trick the OS into thinking it has 8g ram, when it really only has 4. But, we are poor folk, you get what you can afford. But I swear when my 8 year old Dell died, and I bought this thing, I went from a V8, 4X4 to a 4 cyl mini van. But all kinds of different error messages saying "It ain't gonna happen", is where I am LOL, but it isn't funny.

Yes it is W10, I think YUMI is the only major writer I haven't tried. I've got it downloading now. I did realize that I had somehow missed LILI, I had it downloaded I just overlooked running it. But when I tried to run it, it said "Z OS 16 Not on compatibility list, but will try with same settings as Z 06 lite". It said file is corrupted please download again. I have already downloaded 3 times form 2 different sources, the official Z download page, and I just realized I don't remember, but it was one of the Linux sites, or maybe Linux magazine or something, it was reputable anyway. So let's try YUMI.

Is there a specific reason nobody is using dd?

in Windows?

Strongly Recommend Zorin OS Lite on your machine given your description.

I'm in windows no dd, that I know of, I avoid the windows command line, it's like wearing a scuba suit to a kiddie pool. a lot more trouble than it needs to be.


Oh, sorry. I have overlooked that part. :blush:
But dd is cool. :metal:

On Windows I used to use Etcher to flash img files onto USBs and SD cards. But for ISOs I always used Rufus, especially for OS flashing.

Never had any issues with any of them.

1 Like

That project was abandand in 2015.

on Win I used Rufus ...... never a problem

on Linux I use Popsicle

Ventoy so good ..... use it daily, been using it for so long


I assume the OP has double checked the ISO's SHA256 HASH for file integrity???

I haven't seen anybody recommend Unetbootin, you could try that. But something concerns me about all APPS you have tried failing, somethings not right there. First of all, you don't mount an ISO, ever, thats not how it works.

You plug in your USB drive, make sure its been formated, and then you use your USB flash burner software to burn the ISO directly to the USB flash drive. So, no mounting of an ISO file is necessary to burn said ISO file.

So this might be what you are doing wrong. But incase it isn't, then I also would like to take a gander at the condition of the USB drive your using. What size capacity is the USB drive? How old is the USB drive? How many times have you written to that USB drive?

And yes, for people who are already on Linux, I recommend Popsicle, always...

Unetbootin always works for me. Just avoid Balena Etcher.

Ventoy or Rufus, avoid Balena Etcher. It destroys all my usb :slight_smile:

I don't get this guys. I have a Pinephone and a Pinebook Pro, I have prepared SD cards at least a 100 times if not more, and almost all with Balena, and I have never had any problems with it.
Is it HW dependent or something else?

I'm not defending Balena, just so strange people had so bad experience with it.