Anyway to decrease RAM, or reset it without turning off/on the OS?

I got a 6GB RAM, it may be bit rotted a little, idk, need to test that too. But All I have is Thorium browser open with 20 tabs open. And this is how much RAM it uses. I think maybe, when i open other applications & then close then, their temporary memory isnt deleted & still takes up my RAM sometimes until my next restart, i dont know though, thats what it seems like/appears to be, with Zorin & windows.


@Aravisian , thanks! Can you please separate those 3 commands, just so we can be clear, i understand they are all run in the same line though.
Also, which one must u run a 2nd time? all 3? or f.e. just the last part of it?

The three separate commands are:

sudo sync

sudo sysctl -w vm.drop_caches=3

sudo sync

One of those commands is the same each time and it is run twice.
You run sudo sync to sync your current memory and lock it in.
Then you clear out no longer relevant memory with sudo sysctl -w vm.drop_caches=3
Once that has cleared out memory space, run sudo sync again to Unlock your memory and allow active use of RAM to continue.

Another thing you might try:

  1. Uninstall everything you know you won't use. Watch your dependencies, only do the uninstall from the command line, and if you see it wanting to remove any Gnome or Zorin packages, cancel it, that package can't be uninstalled due to dependencies. Keep track of everything you've uninstalled (and the packages that have been uninstalled because they're dependencies)... if you need some functionality back, you'll know quickly which package to reinstall.

Or, if you need some functionality back:

  1. Disable execution of packages that can't be uninstalled but which you know you'll not use. For instance, I disabled Evolution completely:
sudo chmod -x /usr/libexec/evolution-addressbook-factory
sudo chmod -x /usr/libexec/evolution-addressbook-factory-subprocess
sudo chmod -x /usr/libexec/evolution-calendar-factory
sudo chmod -x /usr/libexec/evolution-calendar-factory-subprocess
sudo chmod -x /usr/libexec/evolution-scan-gconf-tree-xml
sudo chmod -x /usr/libexec/evolution-source-registry
sudo chmod -x /usr/libexec/evolution-user-prompter
sudo chmod -x /usr/libexec/evolution-data-server/addressbook-export
sudo chmod -x /usr/libexec/evolution-data-server/csv2vcard
sudo chmod -x /usr/libexec/evolution-data-server/evolution-alarm-notify
sudo chmod -x /usr/libexec/evolution-data-server/list-sources

Or you can navigate (as sudo) to those files, right-click them, select "Properties", select "Permissions", uncheck "Allow executing file as program".

  1. Limit how much your virtual (RAM) file system uses:
# Set up TMPFS from mount -l.
none										/run			tmpfs	rw,nosuid,nodev,noatime,inode64,mode=755,noexec,size=1G								0		0
none										/dev/shm		tmpfs	rw,nosuid,nodev,noatime,inode64,size=1G												0		0
none										/run/lock		tmpfs	rw,nosuid,nodev,noatime,inode64,noexec,size=1G										0		0
none										/sys/fs/cgroup	tmpfs	ro,nosuid,nodev,noatime,inode64,mode=755,noexec,size=1G								0		0
none										/tmp			tmpfs	rw,nosuid,nodev,noatime,inode64,size=1G												0		0
none										/run/user/1000	tmpfs	rw,nosuid,nodev,noatime,inode64,mode=700,uid=1000,gid=1000,size=1G					0		0

If I don't run my cache-preload script, my machine only takes 9 - 10% of memory (1.1 to 1.3 GB).

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.