App windows not remembering position after monitor sleep mode

Hey there guys,

as the title suggests, I have a bit of a problem with my 3rd monitor. Whenever all monitors go into sleep mode, the same app windows always appear on the 3rd monitor when I wake them up and not as I would expect them on the primary monitor (Or let's say where they were displayed before the monitors went into sleep mode).

As I have 3 monitors and have a strict habit where which program/window should be displayed, it is pretty annoying to always place the windows to their previous monitor.

What I did already was:

  • deleting monitors.xml in ~/.config
  • unplugging the 3rd monitor from the graphics card
  • deactivating the 3rd monitor in settings and re-enabling it

to no avail. It's again rather a cosmetic issue, but as I have the timer for deep sleep set to a very small amount, I find myself re-arranging the windows 10-15 times a day which is of course not optimal.

If you have any idea I'd be very happy to hear it. I use an AMD RX 6800XT btw if that helps anything.

Best wishes

This would drive me nuts. It's not cosmetic, it's a complete interruption to work flow.

This is part of why, for me, wmctrl and xdotool are among the very first utilities I install on Zorin Lite.

It's also why I prefer Zorin OS Lite (XFCE) so I can save session on logout- a feature Gnome lacks.

What you can try on (Zorin Core) Gnome:
Delete the monitors.xml file, again.
Position your windows as you want them.
Ensure that libxml2-utils is installed:

sudo apt-get install libxml2-utils

Then paste into terminal:

sudo wget -O /usr/local/sbin/update-monitor-position http://www.calgorithms.com/assets/files/update-monitor-position

Make executable

chmod +x /usr/local/sbin/update-monitor-position

From the Zorin app menu, go to your settings Start Up Applications. Add update-monitor-position to your start up items.

Reboot and test. This really should work...

1 Like

Hey there again,

thank you for your provided solution and taking your time again. However, this did, unfortunately, not solve it :frowning: Any other ideas? :smiley:

The only thing that happened was that my entire monitor setup was re-ordered on boot :cry:

My jaw dropped. I have used that several times...

uhh... I can only suggest you retrace your steps and check everything again.

If not... At least there's Zorin Lite...