Apt not working

after i tried to install O3DE engine and it failed on the post install scripts it started giving me this error

E: The package o3de needs to be reinstalled, but I can't find an archive for it.

Did you install with the .deb package?
https://o3debinaries.org/main/Latest/Linux/o3de_2111_1.deb

Just double click the package to run the installer.

i tried using apt as listed in the how to install guide it gave me an error, now i cant uninstall nor reinstall it, i also have tried this with no success apt - E: The package needs to be reinstalled, but I can't find an archive for it - Ask Ubuntu. also double clicking the installer just give me the error "failed to install file: not supported"

managed to remove it with

sudo mv /var/lib/dpkg/info/o3de. /tmp/

and

sudo dpkg --remove --force-remove-reinstreq o3de
2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.