Asus Zenbook Laptop Brightness not changing

Im using Asus Zenbook Pro Duo laptop.
It has Intel i7 and Intel+ Nvidia (RTX 2060) gfx. 32GB RAM

When I change the brightness, the UI shows up on screen but doesnt change anything in screen brightness.

╭─    /usr/share/X11/xorg.conf.d ····· ✔  at 09:34:59 PM  ─╮
╰─ ls                                                          ─╯
10-amdgpu.conf  10-radeon.conf        70-wacom.conf
10-nvidia.conf  11-nvidia-prime.conf
10-quirks.conf  40-libinput.conf


╰─ cat 11-nvidia-prime.conf                                    ─╯
# DO NOT EDIT. AUTOMATICALLY GENERATED BY gpu-manager

Section "OutputClass"
    Identifier "Nvidia Prime"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "IgnoreDisplayDevices" "CRT"
    Option "PrimaryGPU" "Yes"
    ModulePath "/x86_64-linux-gnu/nvidia/xorg"
EndSection


╰─ cat /sys/class/backlight/intel_backlight/brightness         ─╯
6960

Similar problem with Sound keys, sound always stays at 100% even I reduce it all the way to zero.

Hi, steelx.
Please provide the output of lspci.

1 Like

I’ve experienced problems like you. The screen brightness can’t be adjusted when I haven’t upgraded the RAM to be bigger. however since I have upgraded the RAM (From 2GB to 8GB), I never had that problem.
i am using ASUS a45a.
Try to check the free capacity of RAM.
I don’t know whether this is related or not. I just share my experience.

╭─    ~ ······························ ✔  at 05:53:58 PM  ─╮
╰─ lspci                                                       ─╯
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device a368 (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Device a369 (rev 10)
00:15.2 Serial bus controller [0c80]: Intel Corporation Device a36a (rev 10)
00:15.3 Serial bus controller [0c80]: Intel Corporation Device a36b (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Device a340 (rev f0)
00:1b.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port 21 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port 9 (rev f0)
00:1d.7 PCI bridge: Intel Corporation Device a337 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a30d (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f11 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10f9 (rev a1)
01:00.2 USB controller: NVIDIA Corporation Device 1ada (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1adb (rev a1)
03:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
04:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
04:01.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
04:02.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
05:00.0 System peripheral: Intel Corporation JHL6340 Thunderbolt 3 NHI (C step) [Alpine Ridge 2C 2016] (rev 02)
3b:00.0 USB controller: Intel Corporation Device 15db (rev 02)
3c:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981
3d:00.0 Network controller: Intel Corporation Device 2723 (rev 1a)

thanks for stopping by. but its not RAM issue.

Welcome to the forum @steelx :blush:

Which version and edition of Zorin are you using? Had this exact same issue when I tried the Core edition. Currently using Lite and the brightness is working fine.
You can try xbacklight. Install using sudo apt install xbacklight
after it is installed run xbacklight -set 30, here 30 is the brightness level.

Also is the Nvidia driver installed? If xbacklight is not working try installing that instead of nouveau one.

1 Like

zorin latest. 15.3 Core.

Also I tried what you mentioned. still no effect.

got the latest drivers which came with Zorin os, which I installed yesterday.

You have 2 gpus:
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f11 (rev a1)
Check your BIOS for anything termed similar to “discrete graphics” (or anything where the system is allowed to switch between cards at will) and toggle the settings to turn it on/off. That is the cause of the problem.

You also have 2 sound cards:
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
01:00.1 Audio device: NVIDIA Corporation Device 10f9 (rev a1)
This is also the cause. Again, check BIOS.

1 Like

Solution here (added by moderator): Asus Zenbook Pro Duo 2nd screen display issue - #18 by steelx
steelx original post follows:

Thanks for getting back.
I have Windows 10 + Zorin OS 15.3 installed on 1 SSD.

Attaching screenshot of BIOS, I could not find anything related to term discrete graphics

The one option which I found under Advanced -> Graphics Configuration -> "64M" just a input field (but did not had any toggles or term "discrete graphics")

While you’re there, you may want to look for an option to go with one sound card. If there is no option then try this: https://askubuntu.com/questions/110835/how-to-disable-the-internal-sound-card

There is a way to turn off hybrid graphics: http://www.toontricks.com/2018/03/ubuntu-how-do-i-disable-intel-graphics.html
If the methods in this above link don’t work, you can try the method here: https://help.ubuntu.com/community/HybridGraphics (its solution #2 from the prior link but expanded out a bit more sensibly) - for this one, jump to “These settings are stored in grub’s (the bootloader) own setting files in /etc/default/grub” and start from there.

1 Like