Audio Controller and Built In Audio is turned off after restart/shutdown

When I restart/shutdown, there's no sounds and the Audio Controller and Built In Audio is turned off. But when I turn both of them on, the sounds came back. How can I stop the Audio Controller and Built In Audio to turn off when I restart/shutdown the computer?

Under your startup Applications, is pulseaudio or pulseaudio -D listed?

No. Not listed

You might try adding pulseaudio -D and see if that works.
Otherwise, searching the net for this issue, I came across fifty different references for:

sudo setfacl -m u:$USER:rw /dev/snd/*

Am I gonna add this sudo setfacl -m u:$USER:rw /dev/snd/* in the startup applications? Or do you mean pulseaudio -D? Sorry I'm a beginner at this.

Try adding pulseaudio -D to startup.

The other command is a terminal command. You can try it, if adding pulseaudio to startup does not work.
Open terminal from app menu or with keyboard shortcut ctrl+alt+t
Then paste in:

sudo setfacl -m u:$USER:rw /dev/snd/*

I did both of them but it didn't work

How do you turn on your devices, built-in especially?


I just click the profile button

In your screenshot, it says Unplugged Unavailable.
Any idea why that is?

idk why it says that but the audio works fine though

Is there something I can do to make it plugged and available? But the audio works fine so idk if this is a problem or I should ignore this

It looks like it is defaulting to an HDMI cable - like a monitor or an external monitor.
Are you using a Notebook computer?
If so, have you ever plugged in an external monitor?

No

No, since I only have one monitor

Are you using HDMI monitor on your desktop?

Yes, but it's plugged in. The headphones, front mic, and rear mic also says unplugged although it's certainly plugged in and it's working.

When I added the xset led 3 command in the startup, the keyboard lights automatically turn on when I turn on the computer. So I don't have to type it in the command line anymore.

So is there like some command that I can add in the startup that will specifically turn on the built-in audio on startup?

You might try:

rm -r ~/.config/pulse

In case there was a configuration file causing the issue.
Then:

killall pulseaudio

pulseaudio --start

It didn't work :frowning_face: