Audio detected and connected but not working in most applications

I installed the latest Zorin OS a few weeks ago, all has been well I frequently use my logitech headphones with a USB dongle which works fine on all applications..

But the trouble happens when I try to use my bluetooth speakers, It gets connected even starts playing audio when I try something on firefox, but everything else for instance like spotify and even the "left" "right" test in the settings app fails to work.

Any guidance would be greatly appreciated!

Hi and welcome to the forum.
Can you give us some hardware information, CPU, Graphics, Sound devices.

Can we assume your Logitek headphones are 3.5mm jack wired to the USB soundcard (dongle), because they do not work when plugged direct into to your machines 3.5mm audio jack?

Your machine therefore has more than 1 soundcard, which may be complicating things, especially when bluetooth connectivity is added to the equation.

In terminal, type alsamixer
Hit [F6] and see what soundcards are listed.

You can have a play around inside alsamixer with unmuting channels (select then type "M" to unmute) and volume levels.
Also try toggling Auto-Mute to Disabled.

Hello @zabadabadoo

Thank you for the quick response.

Yes they work only through the USB card

I tried removing it from my machine to make things simpler for now

My CPU is a Ryzen 5800x, I have 2 GPUs an NVIDIA 1060 and an NVIDIA GT 710 that is passed through to a windows machine running with QEMU, I use scream to pass through the audio back from windows to linux as well

In alsamixer I have the following output:

Now just to try something out I remembered from before, I installed pavucontrol and then I noticed that every other app except firefox was actually using the Starship audio device as output even though I had selected STANMORE in the settings for some reason, once I changed that it all seems to work fine (in pavucontrol) manually for each application.

Is there any way to fix the gnome(I presume) sound output selector?

Your HDA nVidia will be HDMI source. Might be better to blacklist that and just have the HD-Audio generic running:

I try to disable Pulse as it is inferior to ALSA - there is an 'apulse' plugin for Firefox.
Just install it from Synaptic Package Manager - if you don't have Synaptic Package Manager now, install it!

It's weird in my /proc/asound/modules I don't see an nvidia section just these three:

 0 snd_hda_intel
 1 snd_usb_audio
 3 snd_hda_intel

Usually, the hdmi connection from an nVidia graphics card shows up as the snd_hda_intel card! :wink:

I know, I was confused as you are!

After blacklisting on my Devuan install:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.