Audio Issues on Zorin OS

Hello everyone,

I'm encountering a frustrating issue with my audio on Zorin OS, and I'm seeking some guidance. I recently performed a clean install of Zorin OS, without dual boot, and I'm currently using a B650 Tomahawk WiFi motherboard. Unfortunately, I've tried numerous troubleshooting steps, including following Zorin OS's official troubleshooting guide, but I'm still unable to get my headset and microphone working properly.

After extensive research, I did find a command that temporarily resolves my headset audio issue:

pacmd load-module module-alsa-sink sink_name="Headphones" sink_properties=device.description="Headphones" device=hw:Audio,1 control='PCM',1

However, this solution is not persistent across reboots, and I'm forced to re-enter the command every time I start my computer.

It's worth noting that my audio functions flawlessly on Windows, which I've installed on a separate hard drive.

Any assistance would be greatly appreciated!

Put that command into the Startup comands:

Start the application "Startup Applications". Click "Add".

Enter the following:
Name: Headphones

pacmd load-module module-alsa-sink sink_name="Headphones" sink_properties=device.description="Headphones" device=hw:Audio,1 control='PCM',1

Comment: Command to get headphones working.

I'm not sure how to get the microphone working... researching...

First, ensure the microphone even shows up...
Go to Zorin menu > Settings > Sound

Scroll down toward the bottom, you should see "Input" and a drop-down box to change the input device. Make sure it's set to your microphone. If it's not, change it to your microphone, then reboot to see if it sticks.


Thank you for your response.

I followed your instructions with the Startup Command. I tried unplugging and plugging back in the microphone cable, and I noticed that the "Microphone - USB Audio" input device disappeared and then reappeared. So, the device should be there. This is similar to what happened with the headphones; they were visible as well but didn't produce any sound. I also checked, that the Microphone isn't muted.

I'm wondering if you can do something similar to what you did for the headphones, for the microphone, via:
pacmd load-module module-alsa-source

Might try something like adding:
load-module module-alsa-source device=hw:1,0 to:

Look all the way at the bottom of that file, where the defaults are set.

I added that to the config and made a reboot, but it didn't seem to work.

Is it a combined USB headset/microphone?
Make model?

No, I got a separated microphone and headset. Both connected via jack.

Interesting that you disconnected/connected 3.5mm mic jack and that changed the "Microphone - USB Audio" status.

From your Settings>Sound input devices dropdown, what other microphone entries are available?

Also lets see what is shown on your Alsamixer settings:
In terminal, type alsamixer
Hit F6 to check sound card is listed.
Hit F5 to display All sound channels.
Check no microphone channels are showing Muted [MM] or low volume.
Unmute by selecting the channel and Hit M

Maybe post a screenshot of your Zorin>Settings>Sound and Alsamixer here so we can see what you have there.

The other sound cards do not have adjustable channels.

It's the same with the microphone. When I disconnect the jack cable, the "Microphone - USB Audio" option is no longer available. But I can't get any sound. I don't see any output in the sound menu or on Discord, for example.

Output devices:

"Speakers - USB Audio"
"Digital Output (S/PDIF) - USB Audio"
"HDMI / DisplayPort - HDA ATI HDMI"

Input devices:

"Microphone - USB Audio" (should be my Mic)
"Digital Input (S/PDIF) - USB Audio"

I found the this, could it be a bug with the internal sound card?

03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device ab30
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device ab30
	Flags: bus master, fast devsel, latency 0, IRQ 146, IOMMU group 16
	Memory at fcb20000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
13:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 1640
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7d75
	Flags: bus master, fast devsel, latency 0, IRQ 148, IOMMU group 32
	Memory at fc988000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
13:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
	DeviceName: Realtek ALC1220
	Subsystem: Micro-Star International Co., Ltd. [MSI] Family 17h (Models 10h-1fh) HD Audio Controller
	Flags: bus master, fast devsel, latency 0, IRQ 149, IOMMU group 36
	Memory at fc980000 (32-bit, non-prefetchable) [size=32K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>

These should be my sound cards.

In Alsamixer F6 Sound Cards what happens if you choose "HD-Audio Generic" ?
Do you see any sound channels with that card selected?

I also found this re ALC1220, scroll to where it says "SOLUTION", don't know if it will work for you, but seen mentioned more than once:

Screenshot from 2023-12-28 16-27-23

I tried the solution, but it changed nothing.

Is the sound source from your Graphics card via HDMI? Take a look at my solution for Soundblaster Card I found on the internet:

After blacklisting, I only had the USB audio sound card. But microphone sound still didn't work.

Screenshot from 2023-12-28 18-16-49

Don't know if this thread helps:

Just found this Spanish article which I have translated bit by bit using DeepL:

"Realtek ALC1220: a problematic sound chip with Linux.
Realtek ALC1220

I recently got a new desktop computer built on an ASUS ROG Strix X370-F Gaming motherboard. The computer was very responsive, but I encountered a problem unheard of in my 10 years as a GNU/Linux user, a sound chip that didn't work properly (regardless of quality).

From then on I started looking for information everywhere and, apparently, the Realtek ALC1220 chip is still not fully supported in Linux, at least on AMD boards. Poking around on the Internet I've seen users reporting issues with the chip, ranging from not working with Ubuntu 17.10 to poor sound quality, either on the output or microphone input. Although the ALC1220 is supposedly supported since Linux 4.11, in Linux 4.13 distributions it doesn't seem to be working properly in many cases, and even with a snapshot of openSUSE Tumbleweed with Linux 4.14 I've had problems.

In my particular case, the problem is electrical noise that creeps in when I play something and noise in general when I'm not playing anything through the left earphone. To rule out that the chip was defective, I decided to install Windows 10 on a hard disk that I had lost around the house. Although the generic Windows 10 driver gave me the same problem, after installing the drivers for the board it disappeared, offering a pretty good sound quality within the limitations that have always accompanied Realtek. My problems with the ALC1220 under GNU/Linux reached such an extreme that, in addition to the annoying noises, I think it was the cause of a couple of system crashes.

I admit that I haven't had the chance to test the ALC1220 chip on an Intel motherboard, but seeing that with Linux 4.14 it still doesn't work properly on my AMD motherboard, I think that some GNU/Linux users still have a lot to suffer with this chip.

Changing the kernel (if a version that supports ALC1220 comes along) could be a solution, but for people like me this is not an option, since this computer is a production-critical machine. So this time I'm going to propose something that may be a bit unorthodox in the Linux world: buying a sound card to replace the on-board sound chip. Obviously, the hardware proposed here can also be used to replace a broken chip or to try to improve the quality in this area.

Temporary solution or for those with a laptop

Notebooks do not offer facilities for an internal sound card via PCI-e, so the best alternative would be to use a card via USB interface, which can also serve as a temporary solution for those who have a tower and are too lazy to open it up.

For these contexts, it may be advisable to purchase a Creative Sound Blaster Play! 2 external sound card, which can be purchased for prices ranging from 21 to 28 euros on Amazon. Searching the Internet, it seems that this sound card is Linux-compatible, so it could be a good temporary replacement for the Realtek ALC1220.

When I say that the sound quality is not decisive, I mean that the user does not demand the best quality, but only that his computer sounds acceptable. For that situation, if you want a definitive solution to replace the ALC1220, you can turn to the ASUS Xonar DSX, which is priced at around 51 euros on Amazon.

This is the card I bought as an alternative to the Realtek ALC1220 and I came to it after reading this article, of which I got good references and I agree quite a lot with what is explained there. The good thing is that it works out of the box, so you just plug it in and it works. It offers an acceptable sound quality with some very occasional "crackling" if you have the volumes of the operating system and an application high. However, it is a solution that can satisfy those who are simply looking for something that works.


The ultimate solution for those looking for good sound quality.

And for users who care about sound quality? In this case I recommend another internal sound card from ASUS, the Xonar DX, which is almost a decade old.

I won't deny that the Xonar DX has one drawback, its high price of almost 70 euros. Despite being an old technology, the Xonar DX is a card with a very good sound quality according to Deligthly Linux, offering a very clean experience in this section and out of the box, so it will work as soon as you put it in the PCI-e slot and turn on the computer. Be warned, though, it does require direct power from the power supply, which the Xonar DSX does not.

The Xonar DX could be a recommendable option for those who deal with sound issues using GNU/Linux.

New sound card sounds at low volume
When using a non-Realtek sound card for the first time, you may find that everything sounds too low in volume, that's because ALSA is taking the speaker output as a separate headphone output from the master channel. To fix this, just go to alsamixer (you can use a graphical interface like gnome-alsamixer or alsamixergui) and turn up the volume of the master channel. Let's describe the steps from the terminal:



Disabling Realtek, a recommended move to avoid problems

If you already have an alternative sound card that is supposedly functional for GNU/Linux, it is advisable to disable the Realtek sound chip in order to avoid problems. To do this, go to the corresponding option in the BIOS, select disable and then exit, saving the changes.

Just to add I purchased what turned out to be a Xonar card from ThinkPenguin while I was struggling with the Sound Blaster card and I could not get it to work. Sent it back to ThinkPenguin who gave me a full refund.

So my obvious solution would be this:

1 Like

I had tried everything. I have now simply fixed it by buying a sound card. Maybe my mainboard is just too new. Thanks anyway!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.