Audio issues

Hi everyone!
I've just finished to fix all the problems I have faced (glad to point out that it was relatively easy on Zorin :slight_smile: )
The last one is purely related to one audio device: I use my speaker connected to the monitor (Samsung Odyssey G5), and I'm currently using shell-volume-mixer GNOME extension cause I often need to swap to headphones or audio interface.
The problem is that it often happens that the audio from the speakers randomly stops, and everytime it happens I have to systemctl --user restart pulse audio, but it doesn't always fix the issue. In these cases, a restart is needed.
Is there something I can do to make it permanently work? The only idea that comes to my mind is driver-related, but I don't know if this is the right path to follow.

Do you have any suggestion?

Thanks in advance!

Does this only occur when using the

Or does it occur whether the extension is enabled or not?

Hi Aravisian, it happens regardless of the extension

What is your terminal output for

sudo lshw -C sound

There you go!

bl4ckk@bl4ckk:~$ sudo lshw -C sound
       description: Audio device
       product: Samson Q2U Microphone
       vendor: Samson Technologies
       physical id: 4
       bus info: usb@1:3.4
       version: 10.03
       capabilities: usb-1.10 audio-control
       configuration: driver=usbhid maxpower=100mA speed=12Mbit/s
       description: Audio device
       product: Tronsmart Glary
       vendor: Barco Display Systems
       physical id: 5
       bus info: usb@1:5
       version: 1.00
       capabilities: usb-1.10 audio-control
       configuration: driver=usbhid maxpower=100mA speed=12Mbit/s
       description: Audio device
       product: TU116 High Definition Audio Controller
       vendor: NVIDIA Corporation
       physical id: 0.1
       bus info: pci@0000:29:00.1
       version: a1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:80 memory:f7080000-f7083fff
       description: Audio device
       product: Scarlett Solo USB
       vendor: Focusrite
       physical id: 1
       bus info: usb@5:1
       version: 6.45
       serial: Y7VACZU157D281
       capabilities: usb-2.00 audio-control
       configuration: driver=snd-usb-audio maxpower=500mA speed=480Mbit/s
       description: Video
       product: HD Web Camera
       vendor: HD Web Camera
       physical id: 4
       bus info: usb@5:4
       version: 1.04
       serial: Ucamera001
       capabilities: usb-2.00
       configuration: driver=snd-usb-audio maxpower=200mA speed=480Mbit/s
       description: Audio device
       product: Family 17h (Models 00h-0fh) HD Audio Controller
       vendor: Advanced Micro Devices, Inc. [AMD]
       physical id: 0.3
       bus info: pci@0000:2b:00.3
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:82 memory:f7700000-f7707fff

For this we have:

I believe that this is your monitor:

This is your integrated motherboard sound:

What is this mystery item? Looks like it may be an Amplifier?

You have two generic drivers - I do not see anything that is vying for control over sound:

Things you can try:
When the sound cuts out, load alsamixer:


tap F6 and look through the hardware output for MM (Muted) on any channels that are for speaker output. See if something is Automuted.
Use pavucontrol

sudo apt install pavucontrol



Go to the Output tab and check the drop down menu for what is set as output.
See if that changes after the sound cuts out.

The mystery item is an audio interface.
Alright, I will try when this happens again, thank you!

This might be due to the sound service suspend-on-idle.

More info:

If you still have issues with audio cutting out, you can try editing /etc/pulse/

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle


### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle

And edit /etc/pulse/

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle


### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle

Then issue:
pactl unload-module module-suspend-on-idle


Another thing is now happening: the sound is really noisy, it seems like there are interferences, and if I change the audio level it actually applies with some delay... this is really strange

Ps: removing and replugging the displayport cable solves the issue...

Edit: it didnt solve, I had to reboot

2nd edit: it is only happening with the speakers. Restarting pulseaudio solves the issue only 10% of times. Maybe there are problems with the cable? But I doubt this, it was working with Windows...

I've tried to apply your solution but I'm still facing the issue reported above.. This is becoming quite annoying

Hi everyone,
does someone know what I can do for this issue?

1 Like

Did you have any results from this?

Also, check if you have both PulseAudio and Pipewire both installed.
Terminal output:

pactl info

Are you saying it solves the interference noises only, or audio stopping as well?

Instead of displayport cable do you have option to use a hdmi cable to the monitor to test if that helps? (but be aware there are different and directional hdmi cables that can exhibit their own issues).

Hi Aravisian,
after applying what Mr_Magoo said I didn't face any audio cut (I hope it was related and it's not just me being lucky).

This is the requested output:

Stringa server: /run/user/1000/pulse/native
Versione protocollo libreria: 33
Versione protocollo server: 33
Locale: sì
Indice client: 20
Dimensione tile: 65472
Nome utente: bl4ckk
Nome host: bl4ckk
Nome server: pulseaudio
Versione server: 13.99.1
Specifica di campionamento predefinita: s16le ch 2 44100 Hz
Mappa del canale predefinita: front-left,front-right
Sink predefinito: alsa_output.pci-0000_29_00.1.hdmi-stereo-extra1
Sorgente predefinita: alsa_input.usb-HD_Web_Camera_HD_Web_Camera_Ucamera001-02.mono-fallback
Cookie: e3ce:d5d4

I've also tried to run "pipewire", here the output:

bl4ckk@bl4ckk:~$ pipewire
[E][000006006.050341][module-protocol-native.c:578 lock_socket()] server 0x56489d4ec380: unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable (maybe another daemon is running)
[E][000006006.050528][conf.c:309 load_module()] config 0x56489d4d27c0: could not load mandatory module "libpipewire-module-protocol-native": Resource temporarily unavailable
[E][000006006.050604][conf.c:383 create_object()] can't find factory spa-node-factory
1 Like

Hi! As mentioned above I'm not facing audio cuts for the moment.
Unfortunately I'm not able to switch to HDMI cause of the actual setup (I do have a laptop which is using the HDMI port and it doesn't have the display port plug, so I cannot switch)

Can you please try disconnecting your Webcam (USB) or Microphone (USB) and reboot.
Then test audio.
I'd like to see if the capture device is snagging audio. Some users have had that trouble and needed to set their capture profile to "off' to resolve.

Sound issues are always a headache... I can imagine that this one wants to make you put your head through a wall.

If he does that he will get interference noise from the neighbo(u)rs! :rofl:

1 Like

Sorry, I didn't get your point! Should I remove mic/webcam and see if the interference noise happens again?
If this is the case, why isn't this happening when I use the headset, but only when I'm using the speakers?

This is driving me crazy...

You said that your audio cuts out and stops working.
I suggested disconnecting USB devices to see it they capturing audio causing the sound to stop working to speakers.

In terms of 'scratchiness', I have had a similar issue on Antix. The solution? Firstly, I don't use Pulse Audio, just ALSA (Advanced Linux Sound Architecture) and use the application QAS Mixer:

The solution? I turned down Pre-Amp as much as possible - problem solved.

However in terms of sound cutting out it can be because there is more than one device available.

See my advice on creating a blacklist.conf to disable audio sources not needed: