Audio not working on Asus eee pc 1001px

I recently installed Zorin OS 16.3 lite on an Asus Eee pc 1001px, dual booting alongside windows 7 starter. The audio doesn’t appear to be working on Zorin but works on windows 7. Any tips on how to fix this audio issue, I don’t want to go back to windows.

Run 'alsamixer' in the terminal to adjust/unmute it.


Try different settings/adjustments.

In alsamixer Hit F6 and see what sound cards are listed. Select the non-HDMI one if you have a choice.
Then Hit F5 to show "All" sound channels. Make sure they are all on screen with none spilling over the right edge. Then post a screenshot here.

And if still having trouble after the above, please return to this thread and post the terminal output for:

sudo lshw -C multimedia

here is the output:

       description: Audio device
       product: NM10/ICH7 Family High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:25 memory:f7cf8000-f7cfbfff
       description: Video
       product: USB2.0 UVC VGA WebCam
       vendor: Azurewave
       physical id: 6
       bus info: usb@1:6
       version: 3.22
       serial: 200901010001
       capabilities: usb-2.00
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s

Drivers are present.
Can you run pavucontrol:

sudo apt install pavucontrol

Launch with alt+F2 > pavucontrol

Under the output tab, under the drop down menu - check what you are set to. You may try setting it to "analog output" if the current setting is not working.

it is still not working

Did you follow this post:

In AlsaMixer, where any channels muted (shows as mm)?
In Pavucontrol, what settings are shown under Output Devices tab and Configuration tab?

i am using the speakers so headphones being muted is fine

Analogue stereo output is no good?

With this window open:

Can you play a sound file of some type and see if the equalizer bar is visibly jumping even if you cannot hear anything?

yes, the bar does move even though i can't hear anything

Well, I see nothing muted and the Drivers seem in place. And the bar is moving. I know you said it is working on Windows... Is this speaker set built in or a USB plug in?

built in speakers

Then we can discount a loose wire. And it works on Windows - so we must assume speakers are good.
What is your output of

uname -r

You might reboot and under Advanced Options for Zorin select a different listed kernel to boot on and test.

If no good, please boot into Windows (assuming this is dual boot) and under Control Panel > Powersave, ensure "fast boot" or "Fast Startup" is turned off. Then, from the power option in the Start menu, select to ShutDown. Ensure Windows fully shuts down and does not go into hibernation.
Then boot into Zorin OS and test sound... again...

In alsamixer move to "Loopback" channel. Toggle that to "Enabled" and test. (That fixed my problem before).
Also unmute all the "Headphone" channels, by selecting each in turn and typing M when selected, then increase the volume slider.
Sometimes fix for sound problems is not logical and requires experimentation.

To save good alsamixer settings do:

sudo alsactl store


It worked! thank you so much!!!

1 Like

Wow, I wasn't expecting that. :exploding_head:
Save those settings.

Make a note of this fix, as if like me, you may have to do it again when updating ZorinOS major version.

i used this video and it worked perfectly for me

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.