Audio not working on Lenovo - Zorin OS Pro 17

Hello everyone,

I'm new to Zorin OS Pro, first and foremost I want to congratulate you on the excellent distribution. I'm a distro hopper, and finally, I believe I've found the operating system that suits me and allows me to work peacefully.

That being said, I recently installed Zorin OS Pro 17 on my Lenovo Yoga Pro 16. Everything is perfect except for the audio; the bass is not working, and it's really unpleasant and barely audible.

I want to mention that this problem is mainly with Lenovo, which should update the BIOS to enable the DSP from there.

My sound card is the Realtek ALC287, and if you search on the internet, there are many discussions about it. I've tried various possible solutions, including compiling the Linux kernel 6.7 myself (I'd prefer not to do it again) because they said the problem was fixed by default from 6.6 onwards, applying patches, putting firmware in the lib directory, but nothing worked.

someone can help me?

Attached are the following information:

alsa-info:

http://alsa-project.org/db/?f=0595eedf07cc64e418a0b4303a15687cd6c00e1d

kernel:

6.5.0-17-generic

A simple option might be to try installing the 6.6.5 kernel without needing to compile it yourself. This is if you have Secure Boot Disabled in your BIOS / EFI settings:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.06

Once done, reboot. Ensure you are on the 6.6.5 kernel with

uname -r

Hi, thank you for the prompt response, unfortunately it didn't work.

uname -r
6.6.5-060605-generic

Perhaps it is not as fixed as they hoped... Or your issue is a different one.

You are spot on about the internet full of discussions on this...

https://bugzilla.kernel.org/show_bug.cgi?id=208555

Unfortunately, I've tried these as well... From what I understand, these patches or alternatives worked on previous versions around ~2020, but on subsequent generations of Lenovo, they no longer work (also, take a look at the open issues on GitHub), and I really don't know what to do... Perhaps it's best for me to wait in the hope that Lenovo updates the BIOS or that another thread emerges providing a definitive solution maybe.

Did you try the fix involving adding the following to /etc/modprobe.d/alsa-base.conf?

options snd-sof-intel-hda-common hda_model=alc287-yoga9-bass-spk-pin

I would guess you already tried it, but if not, several people report it is working, even when the "yoga9" is not their own yoga versions.

One unclear thing from a comment in the link to the bugreport posted by @Aravisian is that one user also say to remove a line from the same base.conf file: https://bugzilla.kernel.org/show_bug.cgi?id=208555#c680

Remove 'options snd_intel_dspcfg dsp_driver=1' and replace the second options line as 'options snd-sof-intel-hda-common hda_model=alc287-yoga9-bass-spk-pin' to get the full (including microphone) support.

When I do a "find in page" search with the above line on the comment thread in the above bug report link, I count four different people that says it works.

Also here is one user from linux mint forum that says it work even he does not have yoga version 9 but version 7: Lenovo Yoga 7i- tinny sound from speakers, but works fine in windows or headphones - Linux Mint Forums

OK. I just poked around on-line and tried a few things. This is what fixed my sound:

I upgraded my kernel to 6.1. edited /etc/modprobe.d/alsa-base.conf, and added the following line at the bottom:

options snd-sof-intel-hda-common hda_model=alc287-yoga9-bass-spk-pin

That fixed the sound issue. I tried the same string with "yoga7" in place of "yoga9" - since I have a yoga7 - but that did not work.

Sound is fixed. Finally. Just upgrading the kernel was not enough - I also had to update the alsa-base.conf file.

If you have tried this, as I think is likely, I am sorry that I post it here. I have absolutely no knowledge of the issue, I just spent some time in Google. Hope I did not wasted your time to much. :slight_smile:

1 Like

A lot of hardware gets special tweaking/tuning by third party manufactures like Bang & Olufsen whereby any open source driver does not produced the equalizer-type sound. So when you try it out on Linux, some of the rich tones/effects are gone. I learned this on my laptop when using Fedora a few years back and noticing the sound was flat versus on Windows 11. Anyway, I recall it did not make a difference when using headphones per my recollection. Maybe they have a special driver for it?

Guys, I finally did it... thanks to Emit, you opened my mind on an issue. Looking at the code here: linux/sound/pci/hda/patch_realtek.c at 99af5b11c57d33c32d761797f6308b40936c22ed · torvalds/linux · GitHub, it's exactly my version as reported by alsa-info (Subsystem Id: 0x17aa387d), hence: ALC287_FIXUP_TAS2781_I2C, this only in kernel version 6.6 onwards. I added this line options snd-sof-intel-hda-common hda_model=ALC287_FIXUP_TAS2781_I2C to the alsa-base.conf file and placed these firmware files https://bugzilla.kernel.org/show_bug.cgi?id=208555#c788 in /lib/firmware/. Rebooted and everything works, even the microphone (yes, it wasn't working). I'm really happy, thanks everyone for the support!

3 Likes