Audio not working

I have been having trouble getting audio to work on a laptop.

Neither the built in speakers or anything connected to the headphone jack works.

In the sound settings the only output device available is "dummy output."

I Already installed PulseAudio and checked the profiles, but all of the outputs are HDMI and are unavailable.

I managed to get sound to work by connecting to another device with an HDMI cable, but haven't been able to get sound to work without it.

Any help would be appreciated.

If using HDMI for sound piping: What graphics card are you using?

Intel UHD graphics 600

Processor is Intel Gemini Lake J4005

Have you checked through all suggestions:

I am getting audio through HDMI but not through laptop speakers or audio jack.

Tried opening alsamixer in the terminal, but the function keys are paired to the computer functions (screen brightness, volume control etc.) and I don't know how to disable them to work in terminal.

Ah, I see. I misunderstood this.

When you launch Pavucontrol, what output options does it offer?

It only shows "dummy output".

In configuration it shows "built in audio" and under profiles it shows HDMI options.

With Intel...
I wonder if this guide here may help, in spite of Zorin OS running a much later kernel...

I tried running the commands in the terminal.

Now instead of "dummy output" it shows "HDMI / DisplayPort"

Still getting no sound from headphone jack.

This is what I see in alsamixer

When profile is set to off it reverts back to "dummy output"

Screenshot from 2022-05-19 22-24-20
Screenshot from 2022-05-19 22-24-42

Bluetooth didn't work before changes and still doesn't work.
HDMI won't transmit audio after changes either.

You added to /etc/modprobe.d/alsa-base.conf the option of options snd-hda-intel model=generic?

Yes, but that didn't work.

I also tried the other option from the web page you posted, but it didn't seem to change anything.

I changed model=generic back to model=auto and HDMI works again.

Admittedly, I usually let those better with Sound issues handle the sound threads. Same for Printers.

I am going to alert @zabadabadoo to this thread, rather rudely... In hopes his greater knowledge on sound issues may fill in my gaps.

In the meantime, please let me search the web and study this issue and see if we can find some clues to what is going on here that hopefully might help us bumble to a solution... Which is how I arrive at many solutions, anyway...

OK. Here goes, but as @Aravisian knows, sound issues are notoriosly illogical and difficult to solve except by trial and error. Do expect lots of error.

Can you tell us what sound card/s you have?


  1. In alsamixer hit [F6], then select a sound card that is not HDMI (if there is one).

  2. Then hit [F5] to show all sound channels.

  3. Post a screenshot.

Whilst you are in alsamixer, if you see any channels marked [M], go across to them and hit "M" key to unmute one by one.

1 Like

f1 - f12 keys control hardware features (screen brightness, volume etc.)
but won't work in the terminal. Only the escape key and arrow keys work in alsa.

Do you know how to fix this?

What machine do you have?
e.g. on some Lernovo laptops, [F1] ..[F12] keys are marked orange and there is a orange [Fn] key.
You have to press [Fn]+[F6] together to do a [F6]

There is only one sound card option that I see.

When I pressed f5 nothing seemed to happen.

Here are the options in system information:

and What sound card other than HDMI do you know have (but not showing in alsamixer)?

If HDMI only, I am unable to offer help except maybe suggest a USB sound card be purchased.

The laptop is a Coolby Xealbook 2022 14.1"

How do I find other sound cards? Is there a device manager for Zorin?

Most use an app: HardInfo
I like it, too.

sudo apt install hardinfo

1 Like