Automated Audio CD ripping

Ok, not necessarily a direct Zorin Issue (posted on Github help forum);
However, via "settings"> "music" set fre:ac as "default application".
regardless, Zorin persists in "proposing" Rhythmbox as player, even when fre:ac is open... As in the image below, under "ripper">"settings"> "automatization",
"read CD contents on insert" (in order to fetch CDDB metadata), as well as
"start ripping automatically" are not select-able...
"auto eject" is, and functions... how to stop Zorin from "proposing" Rhythmbox? (or any other software/player)

I use fre:ac too. I would think the Problem is that fre:ac is not primary a Player. It is a Ripper. I don't know if You need Rhythmbox but if not You could uninstall it and then test if fre:ac will run like you want.

But I find it interesting that you have under Ripper these Settings Menu Entry. I don't have that. I only have the CDDB Entry.

1 Like

sudo apt remove --purge rhythmbox && sudo apt clean && sudo apt autoremove

should uninstall Rhythmbox completely.
@Ponce-De-Leon makes a good point that I am not sure about: Is fre:ac recognized as a Media Player rather than as a media Modifier?

If what you mean by "proposing Rhythmbox" is that when you move to run a media file, it offers to open with Rhythmbox, you can adjust your Mimeapps list to remove Rhythmbox from it.
I get similarly annoyed by opening an image file and it offering to open it in FireFox instead of my default Image Editing software.


My "settings" menu is accessed when clicking on a button (top row)
That appears to have a crossed screwdriver and wrench...
(7th, from left to right... and immediate right of "submit CDDB")
FREAC Command buttons

The version I am using is v1.1.7 - downloaded/installed via Zorin "store" (flatpack)

1 Like

I have the Flatpak Version from the Software Store too. I come to the Settings the same Way. But this Point in the Settings I don't have ... Interesting, but not a bad Thing. Maybe it is because I don't have an integrated CD-Drive. I only have one to plug-in via USB. But Thank You for Your Explanation and Your Screenshot to show.


MY ODD(BD) is in an external 5.25" drive housing... connected via USB 3.2 (gen 1)
resting on my desk... right next to my coffee mug :slight_smile:
FWIW, also removed second BD, in hopes of solving "auto rip" issue (so the machine would know "which one?")

1 Like

Mine is not permanently connected. I only take it off the Closet when I need it.

1 Like

Point noted... (for future reference :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.