"Automatic, DHCP only" not working as expected

When I set the PCI Ethernet port to "Automatic, DHCP only". I do not get the expected global IPv6 IP address. I am assuming that this is the setting for stateful DHCP. Correct me if I am wrong. All I get is the IP address below.

inet6 fe80::1db0:3f9c:2ef7:1683 prefixlen 64 scopeid 0x20

I am testing this in a test lab and the network layout is Zorin laptop -- ASA FW -- DHCP server. On the FW I am seeing the message below and the Solicit packets are being dropped.

IPv6 DHCP: detailed packet contents
src fe80::1db0:3f9c:2ef7:1683 (red)
dst ff02::1:2
type SOLICIT(1), xid 11859016
option RAPID-COMMIT(14), len 0
option IA-NA(3), len 12
IAID 0x667b932a, T1 0, T2 0
option UNKNOWN(39), len 12
option ORO(6), len 8
option CLIENTID(1), len 18
option ELAPSED-TIME(8), len 2
elapsed-time 65535
IPv6 DHCP: Bogus option CLIENTID(1), len 18
IPv6 DHCP_RELAY: Discard SOLICIT with invalid or no options

I tried editing the dhclient.conf file to add a real MAC as the dhcp-client-identifier then rebooted and it did not work. I am not even sure this is the correct thing to do. This is the last thing I need to get working so I can use Zorin on multiple laptops in our lab. Any help would be appreciated.

This could be a result of the 5520 code which is upgraded as far as I can since it is no longer supported by Cisco. I am trying it on a 5525x tomorrow. Also, this setup works with a Windows 10 laptop so my FW config is correct.

It wasn't the older ASA 5520 code that was the problem. I got the same results using the latest code on a 5525x. So it looks to be an issue with Zorin. Any comments would be appreciated.

Hopefully, this guide can help:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.