Background noise when not using audio applications

Hi,
After today’s update I notice very annoying background noise from the speakers when I start Zorin OS 15.3. The solution is to remove the speakers …, I have tried all sorts of ways, but I can’t solve the problem. Before the update, everything worked fine.
The noise stops when I select Audio in Settings (very strange).
Background noise also disappears when I boot a virtual machine with VirtualBox (Ubuntu 20.04) or when I listen to music or watch Youtube …, this means it is due to Zorin OS. Then the noise returns as soon as I return to normal activities …
Thanks Maurizio. I tried to change the speakers but nothing has changed the background noise is always present …

I have actually been experiencing this for a while- including on testing rig of Ubuntu 20.04
I had other suspects entirely but have not solved. But I am tossing this in as a suggestion that it may be possible that it is not a Zorin thing only.

We hope they solve the problem shortly as you cannot use the computer in these conditions …

Thank you Aravisian

M$ coding in the Linux kernel anyone?!

You are not alone with your sound problems, I have one too. The default sounds will not reset back to default, so I’m hoping that it might be fixed later with an update.

Thanks!

Oh yes, not alone. Sound problems are raised often enough and so difficult to treat that in some other thread, I commented that I really dislike touching the threads about sound.
I have noted in the past when trying to research a sound issue on the web after a poster asks about Zorin, a lot of Ubuntu Threads about it. Few Xubuntu threads.
I experienced similar as the OP described recently, but not exactly the same.
In my case, a background noise suddenly comes from the speaker- for bursts of time. It is not constant. I also am in the habit of riding speakers turned off, so I may miss a lot of sounds.)
Experienced on Ubuntu 20.04, as well. Though the OP does not, it is also in a Virtual Environment and I am not sure if that relates or not.
It all makes me wonder if it is an Ubuntu thing in general. And if it is finicky as a problem as to what makes it appear.

It’s an unacceptable problem that it’s hard to live with … It’s worse than not having audio. If they don’t solve it by the weekend I’ll change and try again in six months if all goes well (the problem is that I paid for it …) I will install another distro or Windows, I have yet to decide … Or I only use Mac with the other computer … It is a difficult time for operating systems, even for Macs … Big Sur is terrible!

Very understandable. But I think we can agree that it is not a good solution to not use the OS you paid for.
What fixes have you tried that failed?

Sorry but I don’t understand anything … I’m a beginner.

That is so strange!

Usually a hum sound heard in speakers and or headphones, is due to a ground loop fault somewhere in the source.

However, it is quite common to hear a hum sound from analog computer audio, as the internal DAC’s are usually low quality, and allow signal spill over.

I am using an external DAC that can either use a USB port, or an OPTICAL port, to receive the digital audio signal, process it correctly, and then convert it to analog, in which speakers and headphones can use.

Going this rout will more then likely solve your problem. Cause once you switch the sound routing in the OS to the DAC using a digital connection like a USB port, you will get cleaner sound.

I called MSI service and they collect my computer for repair, probably the motherboard … All under warranty. I’ll keep you updated.
Thanks Maurizio

2 Likes

I had a similar issue in Windows 7, also an MSI mobo (still in use from 2006 but now has FerenOS on it!) I had a sound issue but can’t remember the cause - ooh! think there was some conflict between sound card and TV card (VoodooFX/TV).