Background overlays secondary screen even if I change it (laptop with nvidia)

Hello everybody!

As the title says, I am having a very weird problem, and I'd like to add that I'm a complete newbie when it comes to Linux. I work as a developer and I've recently started getting into linux.

I've got Zorin OS 16.2 installed, on a ASUS TUF Laptop.
I've got an nvidia 1660 TI on it, with nvidia-driver-470 ( propietary ) drivers installed.

I've recently tried updating to the 525 drivers, but the final step failed as I was updating applications in parallel, and forgot about it. The prompt was stuck there and I assumed a restart would help with the issue.
After the restart I noticed that my apps on the laptop's screen became transparent. I couldn't figure out why, so I took a screenshot and sent to a friend, and in the screenshot they weren't transparent anymore.
I've tried changing the background, and the old one was still visible over it, and what's funnier, even when restarting the laptop, while Zorin OS is loading up and during the authentication screen I can still see the background.

This is how the glitch looks. You can see the old background, very faded, over the new one (I'm changing it from my other screen, the one in the video is the laptop's screen)

I've tried downgrading/upgrading the driver again but nothing worked.

1 Like

So apparently a random restart fixed that again. I don't know what caused it, but if someone has an answer for this issue maybe it'll be useful in case someone encounters it in the future.

You may want to go into software updater and check what driver is in use. Since the change failed I'm assuming it's the xorg driver. I had a similar problem recently. Did you attempt the 525 driver or the 525-open? Try going to the 510 driver. If it fails, reboot and try the change again. I'm not sure why it's not taking. My asus complained about missing dependencies, but didn't install anything when running sudo apt --fix-broken install.

You have the A17?

I forgot to add, after the restart I put back the 470 drivers. This was happening with them installed.