"Backups" makes me enter grub every reboot

Ever since I installed Zorin OS 16.2 i have been using the Backups app to keep a copy of the /home on a secondary HDD. Worked like a charm and after some system updates (the ones that pop-up on the screen sometimes), everytime i boot the system it takes me to Grub menu showing the rescue points that bakcups created.

Is it possible to make grub silent again? Without losing the rescue points option if needed?


sudo nano /etc/default/grub

What is GRUB_TIMEOUT_STYLE= set to?

it is set to hidden

In that case, the only thing I can think of is disabling os-prober.
You can do so by adding this line and parameter to the Grub File we just looked at:


Be sure to sudo update-grub after saving and closing the grub file for the change to take effect.

Thanks for the attention, but keeps showing Grub menu (with 30 seconds)

Let's undo the action in the last step then. You don't want to leave the os-prober disabled unless that is your intention.

Is the backup data stored on an external drive?
Or internal one?

Just to mention: everything boots as usual, just need the extra enter at the start

Its an internal HDD single partioned with automont on a folder

So, no other EFI partition.
This is, admittedly, confusing. Because without another partition there, I cannot see why it would offer Deja Dup from the Grub Menu.
Deja Dup allows restoring from Backups - but only from within the Launched Deja Dup (Backups) application. You must have already reached the desktop by then.

My system is updated - and looking at DejaDup, I still only see the same "Restore" functionality that it always had. I do not see a new System Restore from Boot functionality...

And you can see that this makes sense. You are backing up just your Home Directory. Not Root and certainly not /boot directory...

Are you able to grab a photo of this grub menu? Maybe it will provide a clue on what we are missing here.

Yeah, i'm not even dual booting here. Btw I had check the ZFS box at the installation. So this is my SSD partioning (created by zorin itself):

And this is the grub menu that just didnt use appear about 2 weeks ago.

This is under "history for zorin"

Do you have Timeshift or any other system restoration utility?
I see the Grub Menu- I see that if you select History and expand it, it offers the Revert to options...
This is an odd one.
Something is overriding your grub configuration and usually that is os-prober. Do you have Grub Customizer?

Not using any backup tools, just Zorin's one. No grub-customizer also. Just GDM costumizer (lockscreen)

Gday @tuconeves Welcome to the community!

Just another thought, can you check in UEFI if you have the Zorin OS drive (512GB drive) is the first drive to be detected in the bootup order?

1 Like

Good Idea.

Another thing; I was lookign for other areas that may set the grub menu visibility.
In /etc/grub.d/30_os-prober, there is a line at line 35:

set timeout_style=menu

Changing that (elevated to Root in your file manager / text editor) to

set timeout_style=hidden

may help resolve this issue.

1 Like

Hi, guys! Sorry for the week off.

So, I tried every boot entry on UEFI and nothing changes. All of them are bootable except for the P5 purely. And all of them boots on the same grub screen as usual.

Also tried to change the line 35 on os-prober, the same happens.

Why are there two entries that say Ubuntu P5 512gb?

They are all the same Zorin OS.
I don't know why it creates various entries on UEFI. But the same happens on my laptop with fedora.

So, after some research, I have found that APT that is creating those rollbacks point - because of ZFS partitioning.

DejaDup has nothing to do with that, merely coincidence i have set automatic backups by the time.

And because of some bug I could not change the countdown for grub.

Anyway, I yet could not change it.

Also, it looks like the grub files we tried to fix where not the real grub installation. Whenever I got some time, am gonna dive into ZFS partitioning to understand where the real grub is and how to modify it. and i will consider making a new thread about it.

Thank you all for the help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.