Bad Resolution with USB Boot Stick


Zorin OS is starting with a bad Resolution (1024 x 768 (4:3), and it can't be switched to any other settings in the Screenoptions.

I'm using the latest version of Zorin-OS-16.3-Core-64-bit on a USB Stick (installed via balenaEtcher).
When booting i get 4 messages:
-> 0.988301, hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)
-> 3.066787, hid generic 00003:1532:0099:0005: No inputs registered, leaving
-> 3.711518, hid generic 00003:1532:026C:0009: No inputs registered, leaving
-> 4.345164, usb 1-5.4: device descriptor read/64, error -32

from CPU AMD Ryzen 5 7600X, no separate graphic-card installed atm
Monitor LG QHD, connected via DP-Port 1.4

Do you have any ideas how to solve the sesolution-problem?

Which kernel are you on?

uname -r

I ask because the AMD Graphics drivers are included in the kernel.

I don't think Ryzen 5 7600X is intended to be used without a graphics board. This may lead to driver glitches.


I'm assuming you're using on-board graphics via the motherboard? If so, that might be the limits of the graphics output.. weird but, is sometimes limited with some on-board graphics.

What motherboard are you using?

1 Like

I’m using the MSI PRO B650-S WiFi-Motherboard, which displays full QHD-Resolution in Win11 with it’s on-board graphic.
Zorin OS displays Graphic: Ilvmpipe (LLVM 12.0.0, 256 bits)

Hopefully my graphic card (AMD 7800XT) will arrive in the next weeks. When the solution of this problem will be to wait for the new graphic card, i will be fine with that.

1 Like

Gotcha, what do you get with sudo lshw -C video? (screenshot output)

Have you tried other ports for video? I.e., VGA or HDMI? DP might need a driver.. but so might the others. Windows will absolutely have things that Linux will not - but just some, not all.

Do you also have Secure Boot disabled? And also check for amd64-microcode installation: apt search amd64-microcode - if it says [installed] that's good. Still doesn't explain why though but, from the boot messages, I would assume driver related :thinking:

Second the kernel version output - that might point to something as well.

Thank you very much! To disable secure boot solved the problem, i can now enjoy Zorin OS in QHD.


No worries :grin: Definitely good to hear!

Is there an option without disabling secure boot? The game Valorant needs secure boot active to start to start the game.

You can only use Secure Boot (which is for WIndows) if the packages are Signed Packages that Secure Boot will recognize the signature and allow the initialization of that software.
Are you using an unsigned kernel or unsigned software?

uname -r

1 Like

uname -r says: 5.15.0-78-generic

This is a signed kernel.
So it appears that only the graphics drivers themselves are what is unsigned. Sadly,. this means that you cannot enable Secure Boot in order to access Valorant.

This is true of many anti-cheat software games that require TPM 2.0 and Secure Boot because they cater only to Windows Users and neglect MacOS, GnuLinux or other Operating Systems.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.