Balena Etcher problems

Balena Etcher kills usbs as you can read in some forums.
I have been able to check it right now with my usb. It's is absolutely dead.
I can't recover any partition.

I don't understand how a program of that level is included in the installation tutorial.

I hope they pay you enough.


Hi, I’ve never been a fan of Balena Etcher for:

a) in Windows throwing a virus wobbly
b) failed to create a bootable usb.

I can’t comment on whether Balena destroys USB sticks and I guess there could be any number of reasons why it could possibly do that - a memory stick written to over a long period of time - it is on it’s last legs anyway. Poorly (cheap) constructed USB memory sticks.

I will still stick with my outdated MultiSystem on USB (but you need Linux present before you can use it. I don’t reommend Balena Etcher in the Unofficial Manual that I wrote - I think I suggested Rufus as that got a lot of positives from the old forum. My first foray into USB creation was Unetbootin - what turned me away from it was an attempt to create a bootable USB with Zorin on it - after 30 minutes of whirring it stated that it was not supported. That’s when I discovered MultiSystem - you drag an iso over the creation window and if it ain’t going to work it tells you instantly (or it did) but I still use it.

Balena worked fine for me although I prefer using unetbootin since it was faster for me. This has been noted before: but again, as Swarf noted, there exist other reasons for USB failure.

I prefer unetbootin. I have also used Multiboot and I like that one, too.
Have found mkusb to be a powerful utility, as well.
BalenaEtcher never suited me early on and it has been long enough that I cannot remember why I didn’t like it at the time.
I have never used Rufus that I recall offhand, but I have heard good reviews of it.

But does BalenaEtcher destroy USB sticks? That is a very good question and I think sorting the Evidence against Opinion may be more useful:

I have had some close-calls in which I thought a USB stick was killed. But after calming down and patiently doing some troubleshooting, was able to recover things. In one instance, this was due to the USB being corrupted by I/O error being unplugged while writing, with no etcher software involved at all.

Rul, maybe we can continue troubleshooting to help you to double-check the viability of your USB stick.

It appears that balenaEtcher have written some steps on how to recover such USB drives here:


This is the first time I have heard anything negative about Balena Etcher,
I started using it to flash micro-sd cards for my multiple Pine phones.
Since running test operating systems from the sd cards is so quick & simple.
I have since been using B’etcher for my usb sticks as well.
So far I have not had any failures of sd cards or usb drives.
BUT I do only use Linux Distro’s … Maybe it has something to do with
Micro$oft operating systems ?
Some have been re-written dozens of times or more.

I’ve used it on Windows 10 and Linux often, and have never had a problem.

1 Like

Out of curiosity, on Intel powered machines? I’ve only ever built AMD rigs as I don’t trust Intel (and I was right on that one - Meltdown, and not to mention Intel Speed Step).

My desktop CPU is Intel and I only used Balena once on that one and it worked fine. Since then I’ve found that Unetbootin is so much faster and so I never used Balena again.

It’s absolute donkeykong. :upside_down_face:

It’s never worked, no matter how many times I’ve tried. And now I know why Rufus stopped working on that USB drive.

Try running a FOSS based distro on AMD. (I’m not a FOSS advocate, just using it as an example, to make a point.)

Intel with the ME disabled is fine.

AMD has just as much potential for vulnerabilities. This is computing.

But yes, I’ve only every used it on Intel based machines.

1 Like

I think we all have our favourite. I have stuck with Unetbootin as it has proven reliable and easy to use, particularly as I like to include some persistence on a Live USB.

I gave up on persistence because of the contiuous write issue, but there was a member on the old forum who posted a unique method of creating a bootable drive which seemed very clever to me - and I can’t find it now! I think it meant including a FAT32 partition for Persistence, thereby extending the life of the drive. That said, you could always save data to a cloud service then download any data when back at your machine. AMD is no innocent I agree - you only have to remember the other item at the time of meltdown, both suffered from spectre; and possibly here’s why. During a PAT session being carried out where I work I got chatting to the tester of the Electrical equipment and he knew my cousin - small world! But to the point. He told me he visited an AMD factory in Manchester and all this particular guy at the plant was doing was splicing Intel processors apart - he asked if there was any chance he could have an unsliced one - not a chance!
i do remember reading at one point AMD based servers were outselling Intel ones - enter Intel’s response “let’s chuck out all the security on the processors to get us back up to speed again!” :wink:

Thanks so much for the tip !!!

I’ve had it break a USB drive once, was about to send it back but using diskpart on Windows I was able to fix it.

I have also used YUMI Multiboot to have multiple live Linux’s on a single USB stick.

Same experience with The Baltcher but uiso9_pe brought a brand new San Disk 8GB USB right back and used it to install and reinstall Zorin 7 times before it semi works. HP 3005 Pro 64 AMD 8meg & 500GB.

Recommend against BalenaEtcher. I use Unetbootin and never once had any issues whatsoever.
For Windows Users- Rufus.