Battery not charging Zorin OS 15.3 and 16

First, sorry for my poor english (spanish is my original lang)...

My PC is a Lenovo Ideapad Slim 1-14AST-05, and when i plugg the charger it doesn't recognized by Zorin. And the worst part is when i unplugg the charger: the battery "starts to charge", even showing the charging battery icon. I've tried with other distros, but it's all the same... Only Windows 10 works correctly, but i don't want to use win 10 for programming.

= List of distros i've tried =

  • Zorin 14, 15.3, 16 (Lite versions)
  • Lubuntu 20.4
  • Peppermint (newest version)
  • Porteus (this one works, but it doesn't exist an installable version)
  • Xubuntu, Kubuntu
  • LXLE
  • Linux Lite, Linux Mint
  • Q4OS
  • AntiX
  • Bodhi Linux, etc.

Is the battery actually charging but the indicator is wrong. i.e. if charger left connected does the PC actually die when battery meter says low battery and charger disconnected?

EDIT: Maybe something here:

what does

upower -i


Also. Old but maybe useful info here:

1 Like

Yes... I mean, seeking in "power management" it shows the charging working correctly, but the battery doesn't starts to charge. If i unplugg it, the power management still shows the charger connected and the battery "starts" to charge... It's as you typed, the battery functioning is inverted somehow:

Yes that is what is "indicated", but what is happening to the battery itself. i.e. if charger plugged in, does the battery eventually die, or does it infact remain charged?

1 Like

When charger is connected, the battery doesn't discharge but neither charges... If i unplug, the battery shows the charging icon but start to discharge as expected. I've added a link with a video showing the problem:

Difficult one this and not something I have seen myself on any operating system. So all I can do is do websearches and see what comes up.
Have you had a look at the two links in my post #2 above, to see if there is anything there that could help you? Otherwise I am at a loss and have no magic solution for you.

The battery has a sensor that relays information on the battery to the system. Some manufacturers (not many) do not encode their battery sensor in a way that works with Linux.
Not sure if this applies here... but figured I'd mention it.

@zabadabadoo I've read it looking for answers but it wasn't too much helpful; thanks anyway for try to help me.

@Aravisian it could be the reason, this PC is oriented to common secondary/university student, it is not for complex use.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.