Beta 16, kernel installation issues

Hi,

I wanted to install latest kernel but got few errors. Dont know what to do next, any clue ?

Please see if the dependent package resolves; be sure to install the .deb package, then re-install the linux-headers.
http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.33-0ubuntu5_amd64.deb

It seems that I have it already installed.. weird

I found on the web that they have to first publish libc6's 2.33 then kernel 5.12 must be published.
So all I have to wait for a little until libc6's get more recent version .

For example I tried to install 5.11 and no issues.. Except those about missing firmware and module for amdgpu :confused:

I think you saw recent, but now outdated information on the web. I linked the published file, above.

marko@marko-HP-ENVY-x360-Convertible-13-ar0xxx:~/Downloads$ sudo dpkg -i *.deb
[sudo] password for marko:    
dpkg: regarding libc6_2.33-0ubuntu5_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks fakeroot (<< 1.25.3-1.1ubuntu2~)
  fakeroot (version 1.24-1) is present and installed.

dpkg: error processing archive libc6_2.33-0ubuntu5_amd64.deb (--install):
 installing libc6:amd64 would break fakeroot, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.33-0ubuntu5_amd64.deb

-chuckle-
Feels sometimes, like you cannot win, eh?

This is part of the trouble of moving ahead of the tested and vetted updates from Zorin. The unsigned Mainline Kernels lack the porting and patches for the system.
You still have the previous 5.8 kernel, right? You can roll the kernel back to it, if so.

I will try more.. hehe..or will break system xD

Yes , I have 5.8 but atm running 5.11. no issues with that, just cant use latest one ( 5.12 ) :slight_smile: