Better / Scale Grub (Dual Boot Menu)

I dual boot Zorin with Window on my laptop which has a 1440p display. So grub's default makes it almost unreadable. I have the boot order memorized so I know which is which, but it's definitely not professional. A suggestion would be either to scale grub or to use something else which is only logos + labels for the uncommon zorin modes.

I use 1440x900 displays and grub is normal and readbable on mine.
Perhaps your Grub Resolution needs to be changed.
You can check with

sudo nano /etc/default/grub

If the line is present for #GRUB_GFXMODE=640x480, remove the (#) hashtag from it, then set the resolution to a good readable size.
Once done, tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save and exit.
Now, run

sudo update-grub

Reboot and test...

1440p is not 1440 x 900. It 2560 x 1440.

I'm also saying that users shouldn't need to fiddle with grub settings to make the boot UI larger.

1 Like

My mistake. In the meantime, did you perform the steps I outlined above?

I did, it made no difference

GRUB_GFXMODE="1920x1080"

Did you run sudo update-grub? (I often forget to do that part after editing a grub file).

I did that twice, and nope didn't work

And hashtag is removed?
Try without the quotation marks

GRUB_GFXMODE=1920x1080

You need to go into the grub> command line to check what settings are available in VESA. Type videoinfo.

If you’re lucky, another resolution is supported. On my MacBook Pro I only have the native 4k Retina resolution, and AFAIK I have to live with this.

1 Like

This didn't work

Already removed Zorin from my system.

Okay, that is a shame. Just so you know, this is not a limitation with Zorin or grub, but rather the way your laptop BIOS works. Unlike my MacBook, which only supports the native screen resolution, I’m sure yours will support another, but you need to first identify what is supported by the BIOS during boot.

BTW, this has no bearing on screen resolution once booted into Zorin.

I change the grub settings when I use Zorin on my 4Ktv screen, this to make the text to a readable size. Sounds like the same issue you have.

To do this I have scaled the fonts mentioned in the theme in folder /boot/grub/themes and save them in the themes folder which is set in the /etc/default/grub file. You can do this by converting the font.ttf to font.pf2 which is useful for grub.

It's a while ago I did this but if you search the net for converting ttf fonts to pf2, perhaps it can solve the issue.

This thread prompted me to have another try, and I managed to find a suitable resolution even though native was only listed. I also noted that the MacBook ignored the timeout, so added line #3.

This is my current grub.conf:

GRUB_DEFAULT=0
# GRUB_TIMEOUT_STYLE=hidden
GRUB_RECORDFAIL_TIMEOUT=3
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1152*864*32
GRUB_GFXPAYLOAD_LINUX=keep
# GRUB_TERMINAL=gfxterm

Well this file is of course partly responsible for the grub file.
But if you are using the Zorin theme, you should look in the /boot/grub/fonts folder.
The font that's being used by the Zorin theme is name unicode.pf2.

I have a font already converted and copied this to the folder and renamed it as unicode.pf2, now my grub font and text looks like this.

(resized to fit my 4K tv screen)

I changed the font type and size by using that convert command.

If I'm right the command is something like this:

sudo grub-mkfont --output=/home/user/Documents/xUnicode25.pf2 --size=25
/usr/share/fonts/truetype/Amarante/Amarante.ttf

25 - can be the size you prefer
Amarante - is just used as an example. You can use any font that you prefer of course.

(Have not tried .otf fonts but I know .ttf fonts do work)

The xUnicode... file should be rename to Unicode.pf2. But before changing the file you should back-up the original Unicode.pf2 file first, which is present in the /boot/grub/fonts folder.