/bin/sh: línea 1: node: order not found

Greetings, install the nodejs by console then uninstall it, I also tried it by the store and that error still comes out, how do I correct it? the version of nodejs that I tested was 16,17,18 and all of them give me the same error, I use the visual studio code to program, but this error has slowed me down. Thanks for your help. Sorry for my bad English

Does this help?:

But from memory it is currently jre-11? So replace any mention of 6, 7, or 8 with 11 in that post.

1 Like

thanks, but I still get the same error and I try other distributions and if it works but this one doesn't. How do I solve the error, please help.

This error specifically means that node is not found on that path specified (/bin)
Is it installing to /usr/local/bin?

1 Like

how do i correct this problem? or how to install node js there?

There are a few ways, but the simplest would be to export the path:

1 Like

Do you also get this error when you try to run node.js from a terminal window, instead of using the VSCode integrated terminal? It could be it's installed as flatpak or something and has restricted access to the node.js binary.

2 Likes

greetings, thanks I did not understand, I am new in the Linux world

Greetings, from the normal terminal, yes it executes, but the integrated visual terminal counts not, and I want it to execute everything there.

That tells me that VSCode was installed as a flatpak or snap package. Those are isolated environments in which a program runs, so it has less access to other parts of your computer.

How did you install VSCode? If you used the Software store maybe you selected the flatpak or snap options. Nothing wrong with those as long as you understand they have limits to what they can access in the system.

I think the best solution is to download the deb package* from the official website and use that instead. Take note of all the plugins, configuration, etc, before removing the current installation!

*It will start the download automatically.

2 Likes

thanks :slight_smile: , now it works great installing the .deb directly but why didn't it play when I installed it from the store, it's supposed to be better

Best statement on the internet. :wink:

Flatpak and Snap = Not Better.

4 Likes

They are just different package formats, with their own strengths and weaknesses. It just so happens that VSCode's integrated terminal relies on not being isolated.

As you can see, not many people are a fan of those portable formats :smiley:

2 Likes

It clearly raises another question, "Better for who; the Developer or End User?" :poop: