Bind middle mouse to super key not working like in 16.3 (using xbindkeys & xdotool)

I have recently switched from 16.3 to 17.1 and tried to implement my custom key binding I was used to in 16.3. There I have used xbindkeys and xdotool to make the middle mouse button behave like pressing the (left) super key, which was incredibly convenient for switching between workplaces and apps.
However this is not working anymore and I cannot find out why. Have already run through the instructions I used in 16.3 to create the key bindings, but had no effect. Btw I have upgraded with zorins upgrade tool.
Has anyone an idea what the problem could be?

Thank you very much!

Are you using Wayland?
xbindkeys probably doesn't work with Wayland.

Log in using x11.

On the login screen, click on the gear displayed in the bottom right corner and select which window manager will be used.


Just checked your suggestion:

Clicking on the gear icon shows following options:
Zorin Desktop
Zorin Desktop on Xorg

Switching to Xorg didn't solve the problem and running through the binding steps afterwards didn't either.

Any other possible reasons?

Sorry, no ideas at the moment.

As it is an Xorg specific application I thought that switching to it would be

Let's wait for someone with more experience to help.

1 Like

It works now, but I have no idea why.

Will do some testing and post a reproducible solution once I found it!

As in all installs, just like that other OS, needs a restart, and sometimes a system update.