BIOS and Grub Menu not full screen

Since I have been doing "Try Zorin" with Z16 Lite USB, my BIOS screen on startup and also Grub Menu have changed from full screen to smaller centred window.

I have done several reboots into both Zorin 15.3 Core on HD and Windows on same HD via Grub.

In the past, a reboot would fix it, but not this time.

PS: Once Zorin 15.3 or Windows boots, screen resolution is correct.

Whilst both BIOS and Grub screens work OK they are just not full 1280x800 resolution.

Any ideas how this has happened and also how to fix?

PS: Once booted into Zorin 15.3 (or Windows), the screen resolution is correct.

Not sure if this would help you or not.

Have you tried;

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

In grub is line with screen resolution

It is a laptop, not an external connbected screen. So not applicable.

Also BIOS screen not just GRUB has shrunk in size since running the Z16 Lite Live USB.

You might try re-upping Plymouth

sudo apt install --reinstall plymouth

This is a strange one...

OK. I will report back if anything above works.
I may also try my old Z15 Live USB and Restart after that to see the effect if any.
Also wondering if Boot Repair may help.

1 Like

Might be worth a shot. As the efi /boot partition may be affected. What is odd is that the LiveUSB should not have overwritten that record...

OK Folks, I think I have fixed the problem, but I have no idea how it could have been changed in the first place.

I have Phoenix BIOS. As the small display starts off with a reduced size BIOS screen on power-up, then I figured that I the first place to look at settings.

In BIOS Settings > Advanced > Video Features > Compensation
changed from [Disabled] to [Enabled]
F10 to save setting.

Subsequent Cold and Hot Restarts then show full screen BIOS and GRUB screens.

I then went back and set [Disabled] to prove the cause. True enough, small BIOS and GRUB then appeared. So set back to [Enabled].

I just don't know how running a Live USB could result in a BIOS change. I certainly didn't do it manually myself.

Anyhow it seems fixed, so will mark this as "Solution". Thanks for all your replies anyhow.

2 Likes

Had a similar issue on an old Dell brick notebook, can't remember the model name and that too was a BIOS setting. Well done on sorting it out.

1 Like