BIOS getting corrupted whenever I put my laptop to sleep mode!

So, I purchased a new laptop Dell Vostro 5415
It had Windows 11 on it, I wanted to dual boot Zorin. Everything went well and was working fine.
But when I put my laptop to sleep mode and turned it back on and swiped my fingers on fingerprint sensor, the lockscreen started to vanish and the system became unresponsive. And after a minute or so, It turned off completely and was not turing ON!

I removed the backplate and cleared the BIOS by disconnecting the battery and holding the power button for 1 min! After that my laptop booted and I tried to put it to sleep again to check if it still does that. And the same issue persisted.

I am on Windows for now, how can I solve this and why is this happening?

1 Like

Have seen this one but it states that, they fixed it by disabling some out-dated extensions but I have just installed Zorin fresh and the issue was there on first boot!

It does not say anything about outdated extensions. Only that they disabled extensions.
This is not unusual on Gnome with Extensions. Even brand new extensions can conflict or have a corruption.
You can install gnome-tweak tool to easily manage extensions.

sudo apt install gnome-tweaks

In the extensions tab, disable all extensions except the Zorin App Menu (because it is a bit essential and likely to not be the cause) and test if the Desktop Crashes on login.