Black screen after GRUB when using Live USB

I have a Zorin 15.3 Live USB I want to use on my HP Envy x360 (Ryzen 4700U), but whenever I choose any of the GRUB menu items that would Install/Try Zorin I just get a black screen. I’ve tried a known working Zorin 15.1 USB too and the same issue occurs. The issue does not occur when installing Pop OS (20.04), Manjaro, or Ubuntu LTS (18.04), but I would much rather use Zorin.

Here are some points I want to make clear to avoid wasting time:

  • Secure Boot is off.
  • I have successfully booted into other distros on this machine.
  • I do not have an Nvidia graphics card in this machine.
  • The USB is not the issue. It is known to be working, and has successfully installed other distros on this machine.
  • It is not a corrupt ISO issue. I have tried a USB with Zorin 15.1 that has been successfully used to install Zorin on my desktop. The same USB exhibits the same issue I’m describing here.
  • I cannot run any commands on the machine. The screen goes black after selecting the Try/Install GRUB option and I can’t get to a TTY.

As far as I can see, all of these things together indicate a problem with the Zorin ISO itself. So, is there any way around this?

If there’s anything else you need to know about what I’ve done or my system setup, let me know!

Can you please try Aravisian’s suggestions here?

I am currently having the same problem with the same laptop. But the suggested Solution didn’t work for me. Carmar, do you have another idea? Or Pyro, did/how did you solve it?

Different model but same make has a solution that you can try:

Seems like there are quite a few compatibility problems with Ubuntu (albeit, Zorin is 18.04):

First of all, thank you for your fast answer. I tried the first fix twice (although im not 100% sure that I did everything right). But I’m going to try it once more. The second link you sent (if I understand correctly) is only applicable if I can boot it correctly.
Another Thing that may be important: I was able to run Zorin with “Try Zorin” and also after installing it to a second partition on my SSD. The problem was, that I had to reinstall Windows because after the Zorin installation, Windows asked me for a Bitlocker key which I didn’t have.
I called the company where I bought the Laptop (Renewd Laptop) and they told me that the bitlocker encryption was a known bug in Windows 10 and that I had to reinstall Windows. I did as they told me to and know Windows is working fine (without Bitlocker) but I cant boot Zorin.

There are two possible reasons why you can’t boot into Zorin desktop:

  1. Graphics drivers not loading (even though Try Zorin will work, some times the graphics drivers don’t load post installation as you can see in that very first link I cited).
  2. Windows blocking Zorin boot

The first method I cited (Aravisian’s suggestions) is based on assumption #1. sudo ubuntu-drivers autoinstall in a terminal will address that. Are you able to get to a terminal at least with ctrl+alt+F3 (or anything from F1-F6)? That is also a way to fire up the terminal when the system boots but the desktop is not loading.

If it is #2 then there is no need to try ctrl+alt+F3 since Win 10 already blocked Zorin from booting. I have also heard of “Fast Startup” in Windows 10 (#4 listed here) that can cause issues. Thanks for the information on the the bitlocker block - seems like another installation block option from Win 10. The only recommendation I can make here is to try and learn if there are more ways for Win 10 to block Zorin. Unfortunately, I don’t use Win 10 on any of my machines (except my work machine and I can’t experiment on that) to be able to provide any effective troubleshooting of a Win 10 issue.

Sadly none of your recommendations did work (even though Fast startup was still enabled). But one thing I noticed when trying to boot of the USB was the error: file ‘/boot/’ not found.

Were you able to complete Zorin installation successfully from your installation USB drive?

  1. Yes - you don’t need the USB drive after install.
  2. No - there is something wrong with either the USB drive or the downloaded image. See USB boot install on how to check.

If you had an error while booting from USB, that would indicate #2.

Zorin isn’t currently installed, so I’m trying to boot of the usb to install it. But when I select anything in GRUB it just goes to a black screen. I also tried multiple sticks with multiple Zorin editions.

Try the solution in the first hyperlink of my second post.

Already did this multiple times. Didn’t work.

I am confused after reading through this thread.

@ZtormTheCat Are you saying that you have installed Zorin by way of a Live USB, then on restart GRUB appears OK, but if you click on a GRUB menu item you get a blank screen. Is that correct?
What happens if you let GRUB timeout to default i.e. boot Zorin OS?

What does your GRUB screen actually look like?
I guess you won’t be able to post a screenshot, but can you post a photo.

Can you also tell us what method you used to install Zorin. Was is “something else” method or another installation choice?

I had Zorin installed with barely any problems. But I had to reinstall Windows (wiping my complete SSD). And now if I’m trying to reinstall it through an USB, as soon as I select something in GRUB(or if I wait for the timer), I just get a blackscreen. I also tried the fixes carmar suggested, but it didn’t work.

I wonder if you have ended up with >4 partitions on that SSD after Windows reinstallation.
This item from old Zorin forum may be of some use to you:

I am also wondering if running a Boot Repair Disk may do the job. That got me out of a hole once, even running it with defaults. I will try and find that old thread on old Zorin site, but searching for specific thread on that old archive site is a bit haphazard.

… gave up searching old forum. Search function on there is now poor.
I did find this relating to “Boot Repair Disk” elsewhere:


Thanks for your answer. But sadly I only have 4 partitions, so I don’t think that’s the reason. And regarding the Boot-Repair: I can only boot into Windows and I didn’t find a good alternative for it in Windows 10. But I will keep looking.