Black screen after login

Hi, so recently I powered down my device. But when I tried to open it, it got to the login manager, and I logged in. When I did that, the screen only displayed black, with my cursor moving without any problem. I tried rebooting and going into the Wayland session. That worked once. But when I rebooted again, it also didn't work.
Any help please?

What if you power down in X11 instead?

There is nothing I can use to power down except my computer's power button. When I go to x11 and press the power button and reboot, same thing happens.

This sounds like a Display Manager issue.

Can you boot to Grub Menu, then select the Advanced Options for Zorin -(Recovery)
In the recovery menu, arrow to enable networking and enable it. Back up to the recovery menu, then arrow key down to Root - drop to prompt

Tap enter

sudo apt update && sudo apt install --reinstall gdm3

Follow any prompts in the terminal to reconfigure gdm3.

Once done, try a normal boot to test.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.