Black screen after nvidia driver update

Hello, today decided to update my nvidia driver to 525. Rebooted the pc and all I see now is a cursor (underscore). Funny thing is the cursor isn't blinking and I can't type anything. CTRL+F2 does not open the terminal.

I don't know if it's worth mentioning but right before the black screen with static cursor I get a message 'unrecognized AMD processor' however doubt its related as it was working fine before nvidia driver update.

2080ti

Zorin 16.1

Thank You!

Did you use the open or proprietary driver? You could choose advanced in grub and choose the recovery kernel. That will give you a prompt to load a previously working driver, or blacklist nvidia drivers altogether and get back in using the XORG driver (remember to unlist the nvidia drivers then). I have noticed that there are bug reports of the latest nvidia drivers having issue with the kernel drivers. I have not seen to many of these resolved as of yet.

I to switched to the 525 driver, but it didn't install correctly and was unable to revert to the 510 or 515 driver. I'm still running on the XORG driver, content for now until the kernel is patched at the 15.5.0-56 level (patches are always in the newer versions first and rolled back to the older versions).

Hi thank You for the reply, the driver I installed was the one which said (proprietary, tested) next to its name. I can't launch the recovery option, I have dual boot zorin/ubuntu, grub is on ubuntu drive, I can only launch zorin if I select its drive and it just skips grub menu, if I spam 'ESC' key while booting zorin I can enter the grub terminal. Whenever I try to launch zorin directly from grub menu, regardless if normal zorin boot or recovery I get an error saying 'error: file '/boot/vmlinuz-5.*****-generic' not found' and 'You need to load the kernel first'. This is very confusing to me.

I wanted to install them both to separate drives with their own grub, however ubuntu has an annoying bug which hasn't been fixed in a long time now, even if You specify where You want the grub installed it will not do that and it will just override the other grub install.

Would it be possible to delete/disable the driver in some way from my ubuntu installation?

I really wonder why zorin has so many issues with nvidia drivers, on pop os i have zero issues and running the 525 driver a few months by now.

It's not Zorin, it's Ubuntu. Pop may have corrected the issue. The way i understand it, it's a kernel bug that isn't resolved until the 5.16 late kernel.

Pop is a gaming distro and guaranteed to fix any driver issues prior to releasing another version of their OS. I'm sure the Zorin Group is working on a few bugs. I did just see security patches last night, which trump feature or driver bugs.

1 Like

The 5.15.0-57 kernel was just pushed to us, maybe it will resolve driver issues. I'll report back after installation and attempted install of Nvidia drivers.

1 Like

Ok, the 57 kernel automatically installed and is using the Nvidia 510 driver. It said that it had failed, but it's in use. The Nvidia server is not showing anything though. I'm going to attempt to purge my system of nvidia and reinstall by apt.

No matter what driver I choose, I always get the error 10 (313), unless it fails to authenticate, then it just hangs. I tried the 525, 525-open, 510, 515 and 515-open multiple times. I'm still on the Nouveau driver. This was after purging all nvidia drivers with sudo apt remove --purge ^nvidia-.* then sudo apt autoremove to remove the libnvidia files.

dpkg: error processing package nvidia-driver-515-open (--configure):
 dependency problems - leaving unconfigured

is the error I get when in the terminal, finishing with

Errors were encountered while processing:
 nvidia-dkms-515-open
 nvidia-driver-515-open
E: Sub-process /usr/bin/dpkg returned an error code (1)
1 Like

Thank You for information, however I'm still not sure how to recover from this as I am not able to boot into zorin recovery mode from grub :frowning: thinking maybe I'll have to reinstall.