Black screen after suspend - worked fine a couple of days ago

About three weeks ago, I installed Zorin 16 Pro on a second system - a Dell "Precision WorkStation T5500".

I enabled automatic suspend to save power, as the system will be left on most of the time. This worked great, until a couple of days ago. I just pressed a button on the keyboard, and the system woke up.

But now the computer still wakes up (it seems), but the monitor never gets out of standby, and if I switch it on, it just displays "no signal" and goes back to sleep.

So what has happened recently that broke suspend mode, and can it be unbroken?

Here's the system info from neofetch:

OS: Zorin OS 16.2 x86_64
Host: Precision WorkStation T5500
Kernel: 5.15.0-58-generic
Uptime: 41 mins
Packages: 2264 (dpkg), 68 (flatpak)
Shell: bash 5.0.17
Resolution: 1920x1080
WM: Mutter
WM Theme: ZorinBlue-Light
Theme: ZorinBlue-Light [GTK2/3]
Icons: ZorinBlue-Light [GTK2/3]
Terminal: gnome-terminal
CPU: Intel Xeon E5620 (8) @ 2.395GHz
GPU: AMD ATI Radeon HD 5000/6000/735
Memory: 1579MiB / 3905MiB

Hi, see if solution to issue can be garnered from this askubuntu thread as Zorin 16 is based on Ubuntu 20.04:

Most of this thread seems to be about nVidia problems... But I found this bit "if using the driver go into /etc/default/grub and change line 11 to GRUB_CMDLINE_LINUX="nouveau.modeset=0""

I tried - and no change.

I think some update must have caused this. How can I check what updates have been installed, and can they be uninstalled?

I tried booting with the previous kernel version 5.15.0-56, but that did not change anything either. What kernel version shipped with the 16.2 installer?

The kernel version that shipped with 16.2 was 5.15:

[Information Source:]

To check what the most recent installs were:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.