Black screen after 'Try Zorin'


Novice to linux here.

I have a problem installing Zorin on a Surface Pro 9. I understand the SP9's hardware might not mesh well with Zorin, but I don't have another PC to use.

I've seen a similar post here: Black screen of doom on Live Boot: Asus with Intel Iris XE GPU

I've attempted everything that the OP tried, including using safe graphics mode. I've verified the integrity of my ISO which is fine. After searching around, I'm lead to believe that the older kernel and my SP9's IGPU won't work together. As a test, I tried Ubuntu 22.04 which works fine. Really wanting to use Zorin however, any ideas?

Is it possible to get a newer kernel onto the live usb?


here are some things u should try :

  • make sure ur pendrive uses FAT32 file system and uses GPT partion scheme.

  • after u get blank screen wait for 5 minutes, then try launching virtual console using CTRL + ALT + F3 ( i'm not sure if this will work ) and if the virtual console appears, type sudo journalctl -p 3 -xb this command will show the error messages ( show me if u get those error messages ) and exit the virtual console with CTRL + ALT + F1

  • when u get blank screen wait for 30 minutes, there could be a chance that ur pendrive is slow and zorin takes more time to load

You may also need the Surface Pro Linux Kernel:

1 Like

Ahh yes, I've seen this. My linux experience is relatively small, how would I get this kernel working with Zorin if I can't boot into Zorin to make the change?

Thank you

Gday @mrtopkid , Welcome to the community!

Is this a recent purchase of Zorin OS Pro?
If this is the case , for Installation issue's,
Please seek help via the email address provided with-in the email from the ZorinGroup.
keeps us informed.

You can copy the terminal commands to install a new kernel, the old fashioned way (pen and paper), boot into your newly installed Zorin. When you would be at the login screen, press ctrl + F1, use your credentials to log in to the terminal. You can install from here, as if in gnome terminal. Use sudo reboot to reboot the machine and test the new kernel.

1 Like

Hi, Tried you suggestion but still get a black screen. Non responsive to key input.

I was curious, so I tried a usb drive that contains an access led that flashes when data's being read. Immediately after hitting the 'try zorin' (any option), the led flashes for about 2 seconds, then immediately stops. When I managed to try this on another PC, it flashes for a while whilst the drive is checked.

So something is blocking the drive checking? Or is it maybe something similar to the other posts here where the low level graphics stuff isn't being loaded.

As another test, I tried using Cubic to strongarm a later kernel in. This worked on another PC and in a VM on my main PC, but not in the Surface Pro.

Any ideas?


try changing the secure boot configuration to none
u can do this in uefi settings

No difference unfortunately after deactivating secure boot :frowning:

Have you yet tried this tip in regards to the Surface Pro Kernel /Drivers?

i am late but i just realised that surface 9 pro is based on ARM and not x86. meanwhile zorin and most of other distros are made to work on x86 processors.
so that was the reason why zorin wasn't booting


That happened to me once because of my USB drive
Try following this tutorial:How to Install linux without cd or usb | Dualboot | UEFI | Step By Step (2021) - YouTube
You don't even need a USB drive

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.