Black screen issue when leaving suspend mode or screensaver

Hello,

I create a new topic for my issue after a few hours searching for fix on the forum that didn't solve my problem.
My PC is stuck with a black screen (without text or mouse pointer) when leaving the suspend mode. I can't do anything but restart the PC.
It goes in suspend mode nicely but can't start again the session.
I noticed that screen saving (screen turned off after specific time set for power saving) gets stuck as well when return activity on the PC.
But for the screen saving mode, the screen shows the task bar and the notification menu anyway, but this one has limited features instead of the normal features on the session.

So temporarily, I have disabled the screen saving and the suspend mode in zorin settings.
I have tried many fix today by searching the forum for topic related to suspend mode issue but I couldn't solve the problem.

On the picture here are my system specs
Capture d’écran du 2022-08-28 19-24-27
I run ZOrin OS 16.1 Core with 5.15.0-46-generic kernel. Previously, I created 25 GB of a swap partition by following some topic related to hibernation issues, but I gave up with this feature because of the horrible time it takes to switch hibernated or leaving this mode.
I am asking for some help on that issue. I am a relatively new user of linux.

I already thank you for reading my topic.

1 Like

I have forgotten to mention that my pc is on dual-boot with Windows 10. Windows 10 is the prior boot and boots automatically. So when I turn on my computer I have to select manually Zorin OS in order to boot this OS.

Do you have Secure Boot enabled in your BIOS / EFI settings due to having Windows OS installed?
Secure Boot can interfere with Hibernate.

1 Like

I had a similar problem with my laptop containing the lite version of Zorin. The only Solution I managed to achieve was installing and enabling the hibernate option from the terminal and switching all suspend settings with hibernate. It is actually working for me and made things even better. If you want I can Leave the procedure for the following :smile:

5 Likes

Hello Aravisian. Thanks for your reply. I have Secure boot disabled in my bios.
I have just tried again to hibernate zorin os, but it lasts 10 minutes without turning off, so I reset my computer. But my point is to suspend automatically after a period of time. Being able to leave the suspend mode correctly would already be great.

Sure. I am interested in the procedure in case my issue with suspend mode can't be solved.

Use this to enable Hibernate

If not working (special case)

5 Likes

Also, this one didn't work for me, but maybe it does for you :man_shrugging:

5 Likes

Thanks for the links. But I have a question. Do I have to remove previous commands (from today) with the terminal in order to try again properly by following your guide ? I ask that in case there would be interference with the new install, I mean like we have to uninstall a software before resinstalling it ?

No just add the commands, if no change is observed while trying the first article.
Every Article mentioned runs individually and there will be no need for removing anything :smile:

5 Likes